Toyota Owners Club - Toyota Forum Messages

Review Your Toyota

Help others when it comes to buying a car like yours, review your Toyota now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Pennywise

Registered Member
  • Content count

    3
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Pennywise

  • Rank
    New Member

Contact Methods

  • First Name Chris

Profile Information

  • Gender* Male
  • Toyota Model Previa
  • Toyota Year 2002
  • UK/Ireland Location Dorset
  • Interests Travel
    Computers & Electronics
    Sports & Leisure
  1. Is there a plug on the engine block I need to remove (as eariler Previa) to completely drain the coolant or is it just the plug on the radiator for the later model? Thanks
  2. Previa 2002 2.4 Petrol Auto Starting Problems

    Turned out to be those dreaded lambda sensors, had to have 2 of them changed and also the engine temperature sensor.
  3. Hi all, new here, tried a search but couldn't find anything specific. Have recently replaced spark plugs and mass airflow sensor in my Woife's previa. Generally running much better / more smoothly, appears to be using less fuel but warm / hot starting is like Russian Roulette, usually OK but sometimes it's like the engine is flooding even if you don't press the accelerator. It will then only turn over and not start until left to cool down. Can also smell the petrol which is why I think it's flooding. Also the revs are a bit up and down in neutral / park although this has improved since chaging the mass airflow sensor before which it would regularly cut out when pulling out of junctions, etc My Wife wants to get rid of the vehicle having lost confidence in it but I was wondering if there's anything else worth trying? Oh, it's done just under 100,000 miles. Please, anyone, can you help!
  4. Welcome to the Toyota forums Pennywise :)