AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Registered Member
  • Content count

  • Joined

  • Last visited

Community Reputation

19 Good

About igormus

  • Rank
    Top Rank Poster!
  • Birthday 02/25/1963

Contact Methods

  • ICQ

Profile Information

  • Contributor
  • Gender*
  • Toyota Model
    RAV-4 ,2007 (2.0 ltr petrol auto)
  1. Happy Birthday igormus!

  2. Hi Guys many thanks for greetings Cheers
  3. Hello Matey Please consider the below listed reasons with the same -- grey smoke from the rear tail pipe: - clogged engine air filter; - clogged fuel filter; - poor injection of one/two ... injectors mounted; - issue with SCV; - issue with turbo; - poor diesel quality; - MAF sensor is dirty and gives a wrong signal to ECU; - overloading of engine please check and revert regards/Igor
  4. EGR is your enemy with carbon deposits inside. have it cleanned and try to drive cheers/Igor
  5. the problem is the only original is on sale i ve had gases leaks thru a big middle silencer and forced to buy new original
  6. 1. what is the condition of fuel filter??? 2. check with EGR by opening an upper lid (any carbon inside restricting gases passing thru ???) 3. check with flexibility of controlable turbo vanes 4. check with condition of an air filter (engine's) 5. check with turbo VSV regards/Igor
  7. i would change it + paint+ insulate to prevent further corrosion/
  8. i use to change summer's by the end of October/ now +7 C is here in the night
  9. In the title big been on the vodka again.....?
  10. check with an air blockade in cooling circuit first and be sure it has sufficient collant in
  11. you'd decode it first to have some tips to go
  12. what about co-ordination of gas pedal with throttle service motor ? may be motor gets late signal to accelerate engine even though you ve changed gears in time regards/Igor
  13. be focused on possible reasons: - head gasket issue; - thermostatic valve issue; - expansion tank lid rubber gasket issue; - cooling pump mechanical seal issue; - air in the cooling circle; regards/Igor
  14. petrol or diesel ???