Toyota Owners Club - Toyota Forum Messages

Review Your Toyota

Help others when it comes to buying a car like yours, review your Toyota now

In Memory

Les "Giddlepin" Ackroyd - 1951 to 2016  - A well missed friend to everyone. 

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Mick24

Registered Member
  • Content count

    619
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Mick24

  • Rank
    Guru Member
  • Birthday August 8

Contact Methods

  • ICQ
    0

Profile Information

  • Gender*
    Male
  • Toyota Model
    PFL T Sport
  • UK/Ireland Location
    Northamptonshire
  1. Check the ecu for fault codes stored - that will tell you why the engine management lights have come on.
  2. Hi Jerry, Provided you have checked the basics, compression test,plug gaps,valve clearances and fuel filter - then a couple of common problems on the 2E engine in regards to poor cold start are; The cold start enrichment device (wax stat) on the carb fails. The ignitor on the ignition system produces a weak spark and struggles to start a cold engine. The only real solution is to get up to a breakers and get a spare carb and distribtor unit and try them. Mick
  3. Do a compression test on the engine,that will tell you if the internal health of the engine is ok before you go any further. Mick
  4. Dont think it's a MAP sensor - not on a 1998 engine IIRC. It looks like more like a VSV ( vacuum switching valve ). Where does the other end of the blanked off vacuum pipe go to - charcoal canister ?? Mick
  5. If you have checked the other things mentioned in the other thread, then you need to look a bit deeper into it. The idle speed can be adjusted by the screw and locknut - bring it up to 750~850 rpm to start with. With a decent idle speed, crack each injector pipe off in turn to see if the idle speed drops evenly on all 4 cylinders. If one cylinder doesnt drop as much, that will narrow it down a bit. Fuel leakage is normally the main cause of rough idle/ high fuel consumption, so check it again including the seals on the diesel filter. When was the cambelt last changed ? Has it jumped a tooth to give you a poor tickover/ high fuel consumption . Failing that, you will need to get the pump timing checked and the injectors tested.
  6. Could be worn input shaft bearings in the gearbox if the noise goes when the clutch is depressed - can you hear the noise on over-run when driving ??
  7. Any update on this ?
  8. easy enough to replace the bulb once you have the Climate Control panel off.
  9. Hi Janie, you might want to try an online search of breakers yards or ebay to find a mudflap :)
  10. They are obviously clueless !!! Ask them what rpm the Lift is engaged. Below are some extracts from the SAE paper on the developement of the 2ZZ-GE : At engine speeds below 6000rpm, the rocker arm moves according to the low lift roller follower. When engine speed is above 6000rpm, hydraulic pressure is applied to the locking pin, which slides under and locks the high lift slipper follower to the rocker arm. This creates the difference in valve lift, for the rocker arm will now move according to the high lift slipper. When engine speed is below 6000rpm, the return spring pushes the locking pin back, and the high lift slipper is freed. Max Power 135kw/7600rpm Max Torque 180Nm/6800rpm Think you should be demanding a full refund on the vehicle to be honest.
  11. They need to see what the fault codes are stored in the ECU to narrow the lift fault down. Some of the common causes are: Coolant temp sensor Oil control solenoid ( 2 on the engine ) Oil strainer/filters behind the solenoids blocked. Lift bolts worn/broken. The ECU should have reset itself when the battery was disconnected at the time the engine was fitted, so any new fault codes stored will be to do with the new engine. I sometimes get all three lights come up on the dash, but this is due to an Air Pump problem.
  12. hi joanne, if its actually burning that amount of oil then you would see the smoke in the mirrors when your driving. In regards to oil consumption, toyota say 1 litre of oil per 1,000 miles is the max. If it is burning oil that badly, then in my experience it would need a full engine strip and rebuild to rectify the problem. Mick
  13. I would have an independant report done on the vehicle/replacement engine - eg compression test and a cylinder leak down test - might tell you one way or another .
  14. No worries and glad you have got it sorted
  15. Shouldnt take long for the system to pay for itself these days :D and glad to see you have fitted a flashlube system to it - would recommend you check your valve clearances at regular intervals to make sure no valve seat recession occurs even though you have the flashlube fitted.