AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
johnbmaximus

1989 Hilux 2,4L Diesel Cold Start Problem

15 posts in this topic

COLD START PROBLEM ONLY - ENGINE RUNS NORMALLY AFTER INITIAL STARTING.

FROM COLD DIFFICULT TO START - FIRES UP - ENGINE HUNTS AND VIBRATES EXHAUST SMOKY - SETTLES AFTER COUPLE OF MINUTES

Share this post


Link to post
Share on other sites
 

COLD START PROBLEM ONLY - ENGINE RUNS NORMALLY AFTER INITIAL STARTING.

FROM COLD DIFFICULT TO START - FIRES UP - ENGINE HUNTS AND VIBRATES EXHAUST SMOKY - SETTLES AFTER COUPLE OF MINUTES

Have you changed the glow plugs?

Share this post


Link to post
Share on other sites

COLD START PROBLEM ONLY - ENGINE RUNS NORMALLY AFTER INITIAL STARTING.

FROM COLD DIFFICULT TO START - FIRES UP - ENGINE HUNTS AND VIBRATES EXHAUST SMOKY - SETTLES AFTER COUPLE OF MINUTES

Have you changed the glow plugs?

THANK YOU FOR YOUR REPLY. YES GLOW PLUGS HAVE BEEN REPLACED WITH NEW

REGARDS JOHN BURTON

Share this post


Link to post
Share on other sites

Well John like JXP my first guess would`ve been the glow plugs (I know they`re new but are they all working?) so my second guess would be air getting into the fuel system over a period of time dropping the fuel pressure.

3rd Fuel filter (changed recently ?)

Best of Luck bud ! ;)

Share this post


Link to post
Share on other sites

Hi all,

having exactly the same issue now "I have a 1993 2.4 surf", I did notice the black smoke a while back but now it doesn't start at all even though the heaters indicator comes on as it always do. Wait for the clunck and I try starting :crybaby: no joy at all.

Batteries are new and have been checked again and tested OK

I came across many suggestions favouring glow plugs change which I will consider, the main problem is I need a pro grease monkey to help with this. Any advice? anyone in or near Manchester?

Also having problems with turbo not kicking in and this have been going for a while.

Many thanks

Share this post


Link to post
Share on other sites

Morning folks,

After a very bad experience with public transport for the last few days "never liked them anyway and don't know how to use them" :rolleyes:

Today and after reading extensiveliy on this forum and others about the cold start issues and reading the manual. Managed to start the car in one attempt hurrrrray:

As the issue seems to be Glow plugs not heating enough or something, I picked one of the suggestions given here in another post so I waited for the glow coil light to go off > waited for the clunck > turned off the ignition > and again did the same two times and wooooof the beast came to life :yahoo:

Now I know what to change next, thanks to all

I still need help with the turbo issue but this one I'd leave for a pro, any recommendations? any1 knows a mechanic in Manchester who can help?

Best regards

Share this post


Link to post
Share on other sites

COLD START PROBLEM ONLY - ENGINE RUNS NORMALLY AFTER INITIAL STARTING.

FROM COLD DIFFICULT TO START - FIRES UP - ENGINE HUNTS AND VIBRATES EXHAUST SMOKY - SETTLES AFTER COUPLE OF MINUTES

ok your issue with injectors -- have them tested -- some of them pour diesel but not inject.

besides - also check with glow plugs resistance right on the engine. CHeers/Igor

Share this post


Link to post
Share on other sites

Morning folks,

After a very bad experience with public transport for the last few days "never liked them anyway and don't know how to use them" :rolleyes:

Today and after reading extensiveliy on this forum and others about the cold start issues and reading the manual. Managed to start the car in one attempt hurrrrray:

As the issue seems to be Glow plugs not heating enough or something, I picked one of the suggestions given here in another post so I waited for the glow coil light to go off > waited for the clunck > turned off the ignition > and again did the same two times and wooooof the beast came to life :yahoo:

Now I know what to change next, thanks to all

I still need help with the turbo issue but this one I'd leave for a pro, any recommendations? any1 knows a mechanic in Manchester who can help?

Best regards

what is the problem with T/C ??

cheers

Igor

Share this post


Link to post
Share on other sites

Hi Igor,

What do you mean by T/C? sorry for my ignorance :rolleyes:

Too cold today by the way, five attemps and then gave up -14 this morning

cheers,

Share this post


Link to post
Share on other sites

Hi Igor,

What do you mean by T/C? sorry for my ignorance :rolleyes:

Too cold today by the way, five attemps and then gave up -14 this morning

cheers,

hi again

T/C <=> turbocharger

Cheers/Igor

Share this post


Link to post
Share on other sites

Hi Igor,

Since I changed the fuel pump a year ago the turbo won't kick in, You can feel when driving that It loses power and the needle not even reaching three and consumes lots of juice too. Gone through extensive checks but no one could point a finger at what is wrong, wiring OK with all turbo hoses checked.

Problem is my friend, I wish I know anything about mechanics but unfortunately I don't so did the ones who had a look at it. Asked Toyota if they can have a look but they told me they don't have the diagnostics equipments for this model any more.

Because I like this car and really had fun with it when it was fit that's why I want someone reliable to look at it and sort it out once and for all.

Someone suggested changing the fuel pump, so went and bought a second hand one butt before going through changing it I want it checked first then can decide.

I live in Manchester anyone knows any good mechanics around here?

Cheers

Share this post


Link to post
Share on other sites

Hi Igor,

Since I changed the fuel pump a year ago the turbo won't kick in, You can feel when driving that It loses power and the needle not even reaching three and consumes lots of juice too. Gone through extensive checks but no one could point a finger at what is wrong, wiring OK with all turbo hoses checked.

Problem is my friend, I wish I know anything about mechanics but unfortunately I don't so did the ones who had a look at it. Asked Toyota if they can have a look but they told me they don't have the diagnostics equipments for this model any more.

Because I like this car and really had fun with it when it was fit that's why I want someone reliable to look at it and sort it out once and for all.

Someone suggested changing the fuel pump, so went and bought a second hand one butt before going through changing it I want it checked first then can decide.

I live in Manchester anyone knows any good mechanics around here?

Cheers

hi matey

ok let's start again. the T/C is diferent unit as attachable to the engine. now tell me how engine is started/ run as idle -- any bad observations ??? as to T/C -- whether it has variable vanes or fixed?? any photos?do not do anything with pump unless we will discuss about engine. Cheers/Igor

Share this post


Link to post
Share on other sites

Hi Igor,

Since I changed the fuel pump a year ago the turbo won't kick in, You can feel when driving that It loses power and the needle not even reaching three and consumes lots of juice too. Gone through extensive checks but no one could point a finger at what is wrong, wiring OK with all turbo hoses checked.

Problem is my friend, I wish I know anything about mechanics but unfortunately I don't so did the ones who had a look at it. Asked Toyota if they can have a look but they told me they don't have the diagnostics equipments for this model any more.

Because I like this car and really had fun with it when it was fit that's why I want someone reliable to look at it and sort it out once and for all.

Someone suggested changing the fuel pump, so went and bought a second hand one butt before going through changing it I want it checked first then can decide.

I live in Manchester anyone knows any good mechanics around here?

Cheers

hi matey

ok let's start again. the T/C is diferent unit as attachable to the engine. now tell me how engine is started/ run as idle -- any bad observations ??? as to T/C -- whether it has variable vanes or fixed?? any photos?do not do anything with pump unless we will discuss about engine. Cheers/Igor

Hi Igor,

Sorry mate I was down with the flu stuff, OK when I start I can see the turbo light comes on the dashboard briefly then goes off as soon as the truck starts, from then on I notice the car struggles to pick up speed it feels as if it's trying but suddenly the needle goes down to below 3 on rev meter. There is no turbo light at all when driving, it use to come up once you picked up speed. As I mentioned above I took it for checks and was advised all the turbo hoses/ connections are OK but most of them suggested the pump could be misaligned or not fitted properliy? and some advised it needs specialists equipments to diagnonse the fault?

I can try and provide you of pictures if you tel me exactly what do you want me to photograph? Man I wish I did michanics rather than IT as I know nothing more than put disel and drive but I am willing to try with your help guys. At least I did a fair bit being able to follow up on advice given on the forums.

Best regards Igor

Awad

Share this post


Link to post
Share on other sites

Hi Igor,

Since I changed the fuel pump a year ago the turbo won't kick in, You can feel when driving that It loses power and the needle not even reaching three and consumes lots of juice too. Gone through extensive checks but no one could point a finger at what is wrong, wiring OK with all turbo hoses checked.

Problem is my friend, I wish I know anything about mechanics but unfortunately I don't so did the ones who had a look at it. Asked Toyota if they can have a look but they told me they don't have the diagnostics equipments for this model any more.

Because I like this car and really had fun with it when it was fit that's why I want someone reliable to look at it and sort it out once and for all.

Someone suggested changing the fuel pump, so went and bought a second hand one butt before going through changing it I want it checked first then can decide.

I live in Manchester anyone knows any good mechanics around here?

Cheers

hi matey

ok let's start again. the T/C is diferent unit as attachable to the engine. now tell me how engine is started/ run as idle -- any bad observations ??? as to T/C -- whether it has variable vanes or fixed?? any photos?do not do anything with pump unless we will discuss about engine. Cheers/Igor

Hi Igor,

Sorry mate I was down with the flu stuff, OK when I start I can see the turbo light comes on the dashboard briefly then goes off as soon as the truck starts, from then on I notice the car struggles to pick up speed it feels as if it's trying but suddenly the needle goes down to below 3 on rev meter. There is no turbo light at all when driving, it use to come up once you picked up speed. As I mentioned above I took it for checks and was advised all the turbo hoses/ connections are OK but most of them suggested the pump could be misaligned or not fitted properliy? and some advised it needs specialists equipments to diagnonse the fault?

I can try and provide you of pictures if you tel me exactly what do you want me to photograph? Man I wish I did michanics rather than IT as I know nothing more than put disel and drive but I am willing to try with your help guys. At least I did a fair bit being able to follow up on advice given on the forums.

Best regards Igor

Awad

Awad / Igor

You can definitely conside T/C possible fault subject to it has a variable vanes responsible to provide the engine with compressed air. In case the vane pins are partly blocked in their respecting bearing bushes then they become not respond to an engine load. The T/C has vanes adjusting actuator linked to the vanes driving circle and this one can also give a flexibility issue. OK now please make a photo of turbocharger as upper view; both sides view. In general each T/C can be serviced using service kits that are for sale.It is understood all ruber houses must be well joined without an air/vacuum leaks -- cos this leads to a signal lose and finally to your problem. I do not conside the problem is with HP pump thanks to the engine is started well (as far as I ve caught you). CHeers/Igor

Share this post


Link to post
Share on other sites

Hi Igor,

Since I changed the fuel pump a year ago the turbo won't kick in, You can feel when driving that It loses power and the needle not even reaching three and consumes lots of juice too. Gone through extensive checks but no one could point a finger at what is wrong, wiring OK with all turbo hoses checked.

Problem is my friend, I wish I know anything about mechanics but unfortunately I don't so did the ones who had a look at it. Asked Toyota if they can have a look but they told me they don't have the diagnostics equipments for this model any more.

Because I like this car and really had fun with it when it was fit that's why I want someone reliable to look at it and sort it out once and for all.

Someone suggested changing the fuel pump, so went and bought a second hand one butt before going through changing it I want it checked first then can decide.

I live in Manchester anyone knows any good mechanics around here?

Cheers

hi matey

ok let's start again. the T/C is diferent unit as attachable to the engine. now tell me how engine is started/ run as idle -- any bad observations ??? as to T/C -- whether it has variable vanes or fixed?? any photos?do not do anything with pump unless we will discuss about engine. Cheers/Igor

Hi Igor,

Sorry mate I was down with the flu stuff, OK when I start I can see the turbo light comes on the dashboard briefly then goes off as soon as the truck starts, from then on I notice the car struggles to pick up speed it feels as if it's trying but suddenly the needle goes down to below 3 on rev meter. There is no turbo light at all when driving, it use to come up once you picked up speed. As I mentioned above I took it for checks and was advised all the turbo hoses/ connections are OK but most of them suggested the pump could be misaligned or not fitted properliy? and some advised it needs specialists equipments to diagnonse the fault?

I can try and provide you of pictures if you tel me exactly what do you want me to photograph? Man I wish I did michanics rather than IT as I know nothing more than put disel and drive but I am willing to try with your help guys. At least I did a fair bit being able to follow up on advice given on the forums.

Best regards Igor

Awad

Awad / Igor

You can definitely conside T/C possible fault subject to it has a variable vanes responsible to provide the engine with compressed air. In case the vane pins are partly blocked in their respecting bearing bushes then they become not respond to an engine load. The T/C has vanes adjusting actuator linked to the vanes driving circle and this one can also give a flexibility issue. OK now please make a photo of turbocharger as upper view; both sides view. In general each T/C can be serviced using service kits that are for sale.It is understood all ruber houses must be well joined without an air/vacuum leaks -- cos this leads to a signal lose and finally to your problem. I do not conside the problem is with HP pump thanks to the engine is started well (as far as I ve caught you). CHeers/Igor

Thanks once more Igor,

OK now I'll get a few shots taken ASAP so we can have a picture to look at and hopefully have an Idea what the fault might be.

Cheers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0