Jump to content


Photo
- - - - -

Landcruiser Acceleration Problems


  • Please log in to reply
2 replies to this topic

#1 jayo

jayo

    New Member

  • Registered Member
  • 1 posts
  • Toyota Model: toyota landcruiser

Posted 04 March 2011 - 04:19 PM

I've got an Toyota LC4 3L D4D,with 138000mile done. no work ever done to engine only injectors copper washers replaced,, it is hesitating during acceleration, no power at all and very slow to accel from 3800rpm to 4500(the engine sounds like turbo is not working), after 4-5 sec power is back until i change up a gear , and the same thing happens ,the jeep runs fine until it reaches 3800rpm, and theres no engine managment light showing any ideas thanks j

Have something to contribute?

Sign in or register to start a topic...


Sign up to TOC Premium Membership To Remove These Ads

#2 marlot

marlot

    Club Member

  • Registered Member
  • PipPip
  • 88 posts
  • Toyota Model: LC4

Posted 06 March 2011 - 06:54 AM

Sounds like a turbo problem.

#3 igormus

igormus

    Top Rank Poster!

  • Registered Member
  • PipPipPipPipPipPipPipPip
  • 2,909 posts
  • Gender*:Male
  • Toyota Model: RAV-4 ,2007 (2.0 ltr petrol auto)

Posted 17 March 2011 - 03:43 PM

I've got an Toyota LC4 3L D4D,with 138000mile done. no work ever done to engine only injectors copper washers replaced,, it is hesitating during acceleration, no power at all and very slow to accel from 3800rpm to 4500(the engine sounds like turbo is not working), after 4-5 sec power is back until i change up a gear , and the same thing happens ,the jeep runs fine until it reaches 3800rpm, and theres no engine managment light showing any ideas thanks j


hi mate
you must to have several issues with one outcome, as follows:
- clogged air filter;
- clogged fuel filter;
- poor injection;
- partly clogged EGR valve;
- MAF sensoor is partly covered by carbon.
Try to investigate it.
Cheers/Igor


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users