Toyota Owners Club - Toyota Forum Messages

Review Your Toyota

Help others when it comes to buying a car like yours, review your Toyota now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
avensis_toyota

Cold Engine Start Problem, Esp Problem

5 posts in this topic

Hi to all,

I have Avensis 2005, 2.0 D4D engine 115KM(85kw) around 300.000 km (200.000 milles ? ) and I have some problems.

1. Hard start when engine is cold. If I leave my car park over a night its dificult to start it. It wont start, unless if I step a little bit on a gas pedal. Then I can drive all day long, turn off/on angine for a 100x times and It will start normaly. When I park my car at 10 PM and try to start it at 10 AM next day, it wont start normaly again. What it could be a problem? Battery is new also glow plug. What else could be a problem, maybe injector or diesel pump ?

2. From time to time, when i go ONLY to right corner, the ESP light start flashing and I feel that ESP system is trying to take control over the car (taking away the gas) This is happening only in right corners, i nleft everything is normal. But the car still have a grip, no sliding or any reasons for ESP goes ON. I can go 2x times faster on left corner and no ESP wont flash, but in right I go normal (with half of normal speed) and the ESP is going crazy. A week ago I went too fast in corner, the light just pop up and brakes just blocked up ! :ffs: Thanks god the road was empty and I hardly stay on the road. Did anybody else had that kind of a problem, any solution perhaps?

Thank you!

Share this post


Link to post
Share on other sites
 

It sounds like you need to visit your toyota dealer. I know it will cost you money but you have a car that is difficult to start and when it does start does strange things when you are driving. A professional diagnosis may save money in the long term. Good luck

Share this post


Link to post
Share on other sites

Hi!

I also have problem to start engine when it's cold. Did you found solution and what was it?

TNX

bye

Share this post


Link to post
Share on other sites

dont know about your esp maybe a loose sensor or something but i think its always worth chucking a can of injector cleaner in the tank and running it for a couple of hundred miles before an expensive trip to mr t.

Share this post


Link to post
Share on other sites

BG244 is what I'd use over the likes of Forte and Redex...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0