Jump to content


Photo

Cold Engine Start Problem, Esp Problem


  • Please log in to reply
4 replies to this topic

#1 avensis_toyota

avensis_toyota

    New Member

  • Registered Member
  • 8 posts
  • Toyota Model: Avensis

Posted 03 May 2011 - 12:16 PM

Hi to all,
I have Avensis 2005, 2.0 D4D engine 115KM(85kw) around 300.000 km (200.000 milles ? ) and I have some problems.

1. Hard start when engine is cold. If I leave my car park over a night its dificult to start it. It wont start, unless if I step a little bit on a gas pedal. Then I can drive all day long, turn off/on angine for a 100x times and It will start normaly. When I park my car at 10 PM and try to start it at 10 AM next day, it wont start normaly again. What it could be a problem? Battery is new also glow plug. What else could be a problem, maybe injector or diesel pump ?

2. From time to time, when i go ONLY to right corner, the ESP light start flashing and I feel that ESP system is trying to take control over the car (taking away the gas) This is happening only in right corners, i nleft everything is normal. But the car still have a grip, no sliding or any reasons for ESP goes ON. I can go 2x times faster on left corner and no ESP wont flash, but in right I go normal (with half of normal speed) and the ESP is going crazy. A week ago I went too fast in corner, the light just pop up and brakes just blocked up ! :ffs: Thanks god the road was empty and I hardly stay on the road. Did anybody else had that kind of a problem, any solution perhaps?

Thank you!

Have something to contribute?

Sign in or register to start a topic...

Sign up to TOC Premium Membership To Remove These Ads

#2 Druid Boy

Druid Boy

    Guru Member

  • Registered Member
  • PipPipPipPipPipPip
  • 782 posts
  • Gender*:Male
  • Toyota Model: Avensis T3S 2.2 D4D
  • Year: 2006
  • Location: Monmouthshire

Posted 03 May 2011 - 10:22 PM

It sounds like you need to visit your toyota dealer. I know it will cost you money but you have a car that is difficult to start and when it does start does strange things when you are driving. A professional diagnosis may save money in the long term. Good luck

#3 norden

norden

    New Member

  • Registered Member
  • 1 posts
  • First Name:Norden
  • Gender*:Male
  • Toyota Model: Avensis
  • Year: 2005
  • Location: Other/NonUK

Posted 10 February 2012 - 07:19 AM

Hi!

I also have problem to start engine when it's cold. Did you found solution and what was it?



TNX
bye

#4 pault38

pault38

    Advanced Club Member

  • Registered Member
  • PipPipPipPip
  • 110 posts
  • First Name:paul
  • Gender*:Male
  • Toyota Model: avensis 2.2(150bhp)
  • Year: 2007
  • Location: Northamptonshire

Posted 10 February 2012 - 02:55 PM

dont know about your esp maybe a loose sensor or something but i think its always worth chucking a can of injector cleaner in the tank and running it for a couple of hundred miles before an expensive trip to mr t.

#5 Mistermena

Mistermena

    Death befor Disco!...

  • Registered Member
  • PipPipPipPipPipPipPipPip
  • 3,688 posts
  • First Name:Taff
  • Gender*:Male
  • Toyota Model: Celica GT4 205 import
  • Year: 1995
  • Location: Caerphilly

Posted 12 February 2012 - 01:37 AM

BG244 is what I'd use over the likes of Forte and Redex...

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users