Jump to content


Avensis On Autoexpress

  • Please log in to reply
2 replies to this topic

#1 Jas16


    Advanced Club Member

  • Registered Member
  • PipPipPipPip
  • 129 posts
  • First Name:Jas
  • Gender*:Male
  • Toyota Model: Avensis 2.0 D4D T3-X
  • Year: 2006
  • Location: Yorkshire

Posted 31 May 2012 - 02:47 PM

Read this over lunch, seems similar [I haven't gone through previous topics] to someone on this site, it might be you, in which case well done for highlighting the flaw with the product

Also good on Toyota for finally, or eventually, finding the faults and fixing it...shows how one person's effort has saved the pain for many

Good on ya


Have something to contribute?

Sign in or register to start a topic...

Sign up to TOC Premium Membership To Remove These Ads

#2 Parts-King



  • Authorised Trader
  • 10,444 posts
  • First Name:Kingo
  • Gender*:Male
  • Toyota Model: Auris Icon Plus 1.4 Tourer
  • Year: 2014
  • Location: Cheshire

Posted 31 May 2012 - 03:27 PM

I'm sure that chap has posted on here about this issue

Kingo :thumbsup:

#3 Merlin 01

Merlin 01

    Club Member

  • Registered Member
  • PipPip
  • 20 posts
  • First Name:Greg
  • Gender*:Male
  • Toyota Model: Avensis 2011 2.0 d T4
  • Year: 2011
  • Location: Nottinghamshire

Posted 01 June 2012 - 02:44 PM

My painful story was posted in 2 x topics on the forum, Annoying noise, and build quality issues, Auto Express still wanted to publish my story to show the outcome and to let other owners know.

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users