• Huge Range of Toyota Parts
      Huge Range of Toyota Parts
    • Save Up To 15% Off For Members
      Save Up To 15% Off For Members
    • Join Premium & Save
      Join Premium & Save
    • Get Your Club Gear!
      Get Your Club Gear!
    • Review Your Toyota
      Review Your Toyota
    • 1000's Of Toyota Cars For Sale
      1000's Of Toyota Cars For Sale


AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


LoSLucifer

Dash Lights (vsc And Trc Off )

13 posts in this topic

Hello.

I have some lights going on randomly in my car. VSC and TRC OFF suddenly starts glowing.

I have to turn the car OFF to turn the lights off. I do not notice any changes in the car when this happends..

Tryed to get some error codes out but my OBD dont show any error codes...

pleace help.

post-145316-0-58938600-1439538907_thumb.

Share this post


Link to post
Share on other sites
 

Does the TRC switch have any effect on the display?

Share this post


Link to post
Share on other sites

No. If i push the buttons for on/off it does nothing. It stays on all the time if it first have turnd on. i have to turn off the car to get rid of the lamps.

Then i can drive for a long time ( many hours ) or 10 min before it turns on again.... completly random.

Share this post


Link to post
Share on other sites

Any tips?

Share this post


Link to post
Share on other sites

I think that these lights must com on with the slightest problem, mine came on when glow plugs needed changing

Share this post


Link to post
Share on other sites

Unusual dash light behaviour on some Toyota models is an indication that the alternator isn't charging correctly. Could be an early sign?

Share this post


Link to post
Share on other sites

I had the same problem as Old Fiver. TRC, VSC and Check engine were on. An obd2 tester gave the answer for the glow plugs. Switched them, all OK.

Share this post


Link to post
Share on other sites

I recently had these two lights on and when I switched the engine off and restarted they were off, but after travelling a few yards then braking they were back on. I turned out it was the fuse for the brake lights had blown. maybe there is a problem with the electric to the brake lights Mine have been ok since replacing fuse.

Share this post


Link to post
Share on other sites

OK. Many good things to check out here. Ill try testing it out. ;) Posting back when is solved.

Share this post


Link to post
Share on other sites

Problem fixed at Toyota. My susspension had a defective bolt... :S

Share this post


Link to post
Share on other sites

Do you know which bolt..it may help others

Share this post


Link to post
Share on other sites

Sorry. Did not see the question... 

But it did not help. hehe. now its back again. Have no clue whats wrong. 

They usaly come on when i brake down and turn in to my street / garage. 
If i find out what it is ill be shure to remember posting about it this time.. 

Share this post


Link to post
Share on other sites

Check the stop lights. My friend had this erratic problem a year back, when he owned his Avensis estate. Read the following:-

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now