• 1000's Of Toyota Cars For Sale
      1000's Of Toyota Cars For Sale
    • Join Premium & Save
      Join Premium & Save
    • Review Your Toyota
      Review Your Toyota
    • Huge Range of Toyota Parts
      Huge Range of Toyota Parts
    • Get Your Club Gear!
      Get Your Club Gear!
    • Save Up To 15% Off For Members
      Save Up To 15% Off For Members


AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
Billy C

Car Starts But Won't Idle For Long - Help

8 posts in this topic

What causes this on the 2?

I have a 92 rev 2 Turbo and basically it starts but doesn't stay idling for more that 2 secs. I can rev it to keep it running but as soon as i take my foot off it cuts out.

What is it and can i try anything to make it better or will it be a case of replacing something?

Cheers

William

Share this post


Link to post
Share on other sites
 

have you tried adding some Redex to the fuel??

it could just be something as simple as a fuel supply problem, sticky injector etc. The Redex will clean out the fuel paths and may well cure/improve the problem.

Rich

Share this post


Link to post
Share on other sites

Could be an ignition fault, has it been serviced recently?

Is it a bigger problem when it's colder or in damp/wet conditions?

Does the problem still occur when the engine is up to full temperature?

Question overload lol :blink:

Share this post


Link to post
Share on other sites

could be the accelerator cable needs adjusting to pull the linkage back a tiny bit, or find the idle screw and adjust that.

Share this post


Link to post
Share on other sites

Got an aftermarket BOV on there ??

Share this post


Link to post
Share on other sites

no just std bov.

Any ideas?

Share this post


Link to post
Share on other sites
:thumbsup: This might help :D Make sure throttle cable has about 1/4 of free play --if cable is tight this will tell the ECU that the engine is not AT IDLE AND CAN GET THE wrong signal ...There should be a FAST IDLE VALVE near the injector rail with a block conector (the idle valve should be a long- ish cylinder) there is a plunger inside cyl which can stick .Look for bolts holding cylinder to manifold and carefully remove -Clean through hole with carb cleaner then spray some W D 40 through hole shaking cyl at same time ---Switch ign on and remove block conector and work conector in and out -you should HERE the plunger clicking inside - if so replace( turn ign off ) and see if fast idle work s .......

Share this post


Link to post
Share on other sites

Oh man, wish i knew my way around the 2.

Anyone know the link for the online MR2 Manual?

Cheers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0