Jump to content


Photo

O2 Sensor Bank 1 Sensor 1 Replacement P0135


  • Please log in to reply
10 replies to this topic

#1 twista501

twista501

    Club Member

  • Registered Member
  • PipPip
  • 36 posts
  • Toyota Model: Avensis 2.0 SR 2001

Posted 04 September 2006 - 12:12 PM

After a recent visit to the dealers regarding a management light, they told me that their system was showing the following code:

P0135 Oxygen Sensor Heater Circuit (Bank 1 Sensor 1).

Ive read a few topics on O2 sensors after this and decided to replace it myself due to the 200 charges labour, parts etc. These cost <20. Does anyone know where this particular sensor is because I understand there are FOUR?

I have a 2001 SR 2.0l VVTi. I see the two sensors in front of the engine one pointing straight out the front - circled red and the other at an angle to the right - circled green (looking straight on). Is it one of these or do I have to look underneath?

Thanks for your help (see pic).

Posted Image

Have something to contribute?

Sign in or register to start a topic...

#2 uumode

uumode

    Advanced Club Member

  • Registered Member
  • PipPipPipPip
  • 342 posts
  • Toyota Model: Avensis hatchback 1.8 T4 auto | Mercedes E240 auto

Posted 04 September 2006 - 12:27 PM

Don't know myself, but something here might be useful?
http://techdoc.toyot...asp?d=1&lang=En

#3 martbatch

martbatch

    New Member

  • Registered Member
  • 4 posts
  • Toyota Model: Avensis 2.0 GLS 2002

Posted 04 September 2006 - 01:26 PM

After a recent visit to the dealers regarding a management light, they told me that their system was showing the following code:

P0135 Oxygen Sensor Heater Circuit (Bank 1 Sensor 1).

Ive read a few topics on O2 sensors after this and decided to replace it myself due to the 200 charges labour, parts etc. These cost <20. Does anyone know where this particular sensor is because I understand there are FOUR?

I have a 2001 SR 2.0l VVTi. I see the two sensors in front of the engine one pointing straight out the front - circled red and the other at an angle to the right - circled green (looking straight on). Is it one of these or do I have to look underneath?

Thanks for your help (see pic).

Posted Image




After a recent visit to the dealers regarding a management light, they told me that their system was showing the following code:

P0135 Oxygen Sensor Heater Circuit (Bank 1 Sensor 1).

Ive read a few topics on O2 sensors after this and decided to replace it myself due to the 200 charges labour, parts etc. These cost <20. Does anyone know where this particular sensor is because I understand there are FOUR?

I have a 2001 SR 2.0l VVTi. I see the two sensors in front of the engine one pointing straight out the front - circled red and the other at an angle to the right - circled green (looking straight on). Is it one of these or do I have to look underneath?

Thanks for your help (see pic).

Posted Image



Hi there,

I had exactly the same error message on my Avensis and the dealer changed the right hand sensor (the one you have ringed in green). The charge, as you say, was 200. It took all of 20 minutes. The sensor cost 114 + VAT.

I now have the engine light up again and will find out tomorrow how much it will cost this time.

Bye

#4 twista501

twista501

    Club Member

  • Registered Member
  • PipPip
  • 36 posts
  • Toyota Model: Avensis 2.0 SR 2001

Posted 04 September 2006 - 02:26 PM

Hi there,

I had exactly the same error message on my Avensis and the dealer changed the right hand sensor (the one you have ringed in green). The charge, as you say, was 200. It took all of 20 minutes. The sensor cost 114 + VAT.

I now have the engine light up again and will find out tomorrow how much it will cost this time.

Bye



hey jus to let you know, i got this link from another topic on TOC:

http://cgi.ebay.co.u...em=250017482352

you can get them for <20 on ebay. im gonna try replacing it and let you know how it goes. are you sure it was the same code and O2 sensor circled in green?

how long has it been since yours was changed and the light came back on? were your 'VSC' lights on as well before you had the O2 sensor change? because mine are but dealer says it is not related.

thanks!

#5 uumode

uumode

    Advanced Club Member

  • Registered Member
  • PipPipPipPip
  • 342 posts
  • Toyota Model: Avensis hatchback 1.8 T4 auto | Mercedes E240 auto

Posted 04 September 2006 - 06:25 PM

Hope you guys get it sorted on your Toyotas.

The problem is very common on VW and can be very hard to cure on a VW car.
if you have the time, scroll down a bit to the 1st Sept post and read on.... a LOT of engine management EPC check lights coming on for no reason or very difficult to solve on VWs.
http://www.drizzten....ves/000193.html

If your VSC light sometimes lights up could be your battery is not 100% and some Kwik Fit type places offer free battery checks.

#6 rf76

rf76

    Advanced Club Member

  • Registered Member
  • PipPipPipPip
  • 125 posts
  • Gender*:Male
  • Toyota Model: 1998 R Avensis 1.8 GLS 4dr Saloon

Posted 04 September 2006 - 11:13 PM

Bank 1, Sensor 1 is the top left sensor as looking at engine from the front. Bank 2, Sensor 1 is the lower left side sensor.

#7 twista501

twista501

    Club Member

  • Registered Member
  • PipPip
  • 36 posts
  • Toyota Model: Avensis 2.0 SR 2001

Posted 04 September 2006 - 11:56 PM

Bank 1, Sensor 1 is the top left sensor as looking at engine from the front. Bank 2, Sensor 1 is the lower left side sensor.


so you're saying bank1 sensor1 is the one circled red? how many o2 sensors are there?

#8 funkyg

funkyg

    Advanced Club Member

  • Registered Member
  • PipPipPipPip
  • 247 posts
  • Toyota Model: 2001 Avensis CDX Saloon 2.0 vvti

Posted 05 September 2006 - 09:24 AM


Bank 1, Sensor 1 is the top left sensor as looking at engine from the front. Bank 2, Sensor 1 is the lower left side sensor.


so you're saying bank1 sensor1 is the one circled red? how many o2 sensors are there?


I had been told that Bank 1 Sensor 1 was top right (the green one). From this link on the forum:-
http://toyotaownersc...;hl=bank sensor
Can anyone give us a definitive answer?

There are four altogether. The two that you have circled, and if you then follow the exhaust down (below the silver coloured manifold cover) you'll see another two.

Also, another guy on here bought one of those cheapy ones off ebay (see link above) and it didn't fix his problem. The engine management light came back on again.

I have the same car (2001 2.0 vvti, looks just like your avatar!) and have the same problem.
I just haven't got the 114 quid for a new sensor at the moment.

Funkyg

#9 twista501

twista501

    Club Member

  • Registered Member
  • PipPip
  • 36 posts
  • Toyota Model: Avensis 2.0 SR 2001

Posted 06 September 2006 - 04:42 PM



Bank 1, Sensor 1 is the top left sensor as looking at engine from the front. Bank 2, Sensor 1 is the lower left side sensor.


so you're saying bank1 sensor1 is the one circled red? how many o2 sensors are there?


I had been told that Bank 1 Sensor 1 was top right (the green one). From this link on the forum:-
http://toyotaownersc...;hl=bank sensor
Can anyone give us a definitive answer?

There are four altogether. The two that you have circled, and if you then follow the exhaust down (below the silver coloured manifold cover) you'll see another two.

Also, another guy on here bought one of those cheapy ones off ebay (see link above) and it didn't fix his problem. The engine management light came back on again.

I have the same car (2001 2.0 vvti, looks just like your avatar!) and have the same problem.
I just haven't got the 114 quid for a new sensor at the moment.

Funkyg



Just bumping this topic up as we dont have a definite answer on the O2 Sensor yet. I reckon it is the green one as well. Anyone know for sure?

Im gonna try the cheap one on ebay its only 20quid as he said in the other topic so worth a shot. Will let you know how it goes. Btw how you finding the SR?

#10 funkyg

funkyg

    Advanced Club Member

  • Registered Member
  • PipPipPipPip
  • 247 posts
  • Toyota Model: 2001 Avensis CDX Saloon 2.0 vvti

Posted 06 September 2006 - 05:01 PM

martbatch said the dealer replaced the green one, so that's the way I'm leaning.
Let me know how you get on with the ebay sensor, I may yet be tempted! I actually PM'd the other guy that tried it and it didn't work for him.

Mines actually a CDX, saloon rather than hatch..
I've had it about 18 months now and on the whole I love it, but I have had a few niggly problems.
This O2 sensor, squealing alternator belt, stereo stopped working, horn, drivers airbag and steering wheel stereo controls stopped working (all three in one go!), the sat nav stopped working.

All things condidered though they are only small issues (the car has never failed to start or get me where I need to go), and I am really racking up the miles, so some of it could be attributed to that. I could have a had this or a similar specced/aged/miles Mondea Ghia X. Some days I think I made a mistake, but most other days I'm glad I chose the car that I did.
I love the fact that I have air con AND a sun roof. The sat nav is OK, when I forget the Tomtom. The stereo is really good, although I don't use the CD changer that much since getting an iPod. And I love the feel of the leather, but hey, maybe that's just a fetish of mine! :D

Funkyg

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users