Jump to content
Do Not Sell My Personal Information


Avensis D4d Problem (53 Plate)


Paul1234
 Share

Recommended Posts

My avensis cuts out when idling

it only occurs when the vehicle is warm

the idling speed seems to be consistently low (800rpm) down from where it used to be by 100rpm

can happen and no fault codes appear

seems to be that the revs drop a little too much and the vehicle cuts out

any help would be appreciated

don't want to be paying through the nose for Toyota to play pin the tail on the donkey

Link to comment
Share on other sites


My avensis cuts out when idling

it only occurs when the vehicle is warm

the idling speed seems to be consistently low (800rpm) down from where it used to be by 100rpm

can happen and no fault codes appear

seems to be that the revs drop a little too much and the vehicle cuts out

any help would be appreciated

don't want to be paying through the nose for Toyota to play pin the tail on the donkey

hello Paul

- how fasty it cuts off after have been started?

- by the way -- how it is started in cold condition? any odservations?

- what were RPM before, let's say a month ago -750?800?900? -do you remember?

- when fuel filter was last changed?

- what are your observations with regards to acceleration?

- have the engine started and hold yr hand 100 mm from the tail exhaust pipe and advise whether an exhausts are equal?

Please come back/Igor

Link to comment
Share on other sites

My avensis cuts out when idling

it only occurs when the vehicle is warm

the idling speed seems to be consistently low (800rpm) down from where it used to be by 100rpm

can happen and no fault codes appear

seems to be that the revs drop a little too much and the vehicle cuts out

any help would be appreciated

don't want to be paying through the nose for Toyota to play pin the tail on the donkey

hello Paul

- how fasty it cuts off after have been started?

- by the way -- how it is started in cold condition? any odservations?

- what were RPM before, let's say a month ago -750?800?900? -do you remember?

- when fuel filter was last changed?

- what are your observations with regards to acceleration?

- have the engine started and hold yr hand 100 mm from the tail exhaust pipe and advise whether an exhausts are equal?

Please come back/Igor

besides -- how fastly are RPM dropped before cutting off? or RPM get plaied?

what did you mean as WARM engine?? did you mean when the themp has reached a midle level or just during heating up???

it is essential. I have some thought in my head but can not play with statements.

Cheers/Igor

Link to comment
Share on other sites

currently running with some redex which has marginally improved the situation

- how fasty it cuts off after have been started? usually needs to be up to normal running temp although it failed after a mile today. Typically fails when revs are dropping after coming to a stop or just after stopping.

- by the way -- how it is started in cold condition? any odservations? The car was occassionally getting difficult to start, with redex starts first time at the moment,

- what were RPM before, let's say a month ago -750?800?900? -do you remember? I think it was running around 900 previously, now slightly above 800. After driving it seems to start idling at 850 and then drop to slightly above 800 and hold

- when fuel filter was last changed? <5000 miles ago

- what are your observations with regards to acceleration? good although I sometimes feel a "drag" intermitantly. Car still does manufacturers bhp output with 190k on the clock (rolling road test by garage checking it) mainly good

- have the engine started and hold yr hand 100 mm from the tail exhaust pipe and advise whether an exhausts are equal? single pipe exhaust

how fastly are RPM dropped before cutting off? or RPM get plaied? the revs just seem to fall away, I have observed them get as low as 750 and recover, I assume any lower they continue to fall away, the dashboard lights stay on the engine just stops

what did you mean as WARM engine?? did you mean when the themp has reached a midle level or just during heating up??? usually at normal runing temp (middle level), can fail after a mile (rarer)

It does seem like fuel starvation at idle

can the idle speed be manually adjusted?

Cheers Paul

Link to comment
Share on other sites

currently running with some redex which has marginally improved the situation

- how fasty it cuts off after have been started? usually needs to be up to normal running temp although it failed after a mile today. Typically fails when revs are dropping after coming to a stop or just after stopping.

- by the way -- how it is started in cold condition? any odservations? The car was occassionally getting difficult to start, with redex starts first time at the moment,

- what were RPM before, let's say a month ago -750?800?900? -do you remember? I think it was running around 900 previously, now slightly above 800. After driving it seems to start idling at 850 and then drop to slightly above 800 and hold

- when fuel filter was last changed? <5000 miles ago

- what are your observations with regards to acceleration? good although I sometimes feel a "drag" intermitantly. Car still does manufacturers bhp output with 190k on the clock (rolling road test by garage checking it) mainly good

- have the engine started and hold yr hand 100 mm from the tail exhaust pipe and advise whether an exhausts are equal? single pipe exhaust

how fastly are RPM dropped before cutting off? or RPM get plaied? the revs just seem to fall away, I have observed them get as low as 750 and recover, I assume any lower they continue to fall away, the dashboard lights stay on the engine just stops

what did you mean as WARM engine?? did you mean when the themp has reached a midle level or just during heating up??? usually at normal runing temp (middle level), can fail after a mile (rarer)

It does seem like fuel starvation at idle

can the idle speed be manually adjusted?

Cheers Paul

hello

OK - start to change fine fuel filter + have both SCV solenoids tested.

ONce done please revert with trials results.

NB - - have the engine started and hold yr hand 100 mm from the tail exhaust pipe and advise whether an exhausts are equal? single pipe exhaust ----> you have misunderstood me ----> I meant that the exhaust gas pressure felt by your hand must be equal in all cyls exhaust strokes and without any rhythm fail.

Cheers/Igor

Cheers/Igor

Link to comment
Share on other sites


fuel filter has been changed and the fault is still there

a fill up without adding redex has meant the problem seems more frequent than before

what is the SCV solenoid? how many are there? and what do they do?

what range of cost to replace?

Link to comment
Share on other sites

fuel filter has been changed and the fault is still there

a fill up without adding redex has meant the problem seems more frequent than before

what is the SCV solenoid? how many are there? and what do they do?

what range of cost to replace?

hello again

FYI -- there are two types of valves:

- normally open;

- normally closed.

So, the task of SCV is to allow the diesel to be sucted into the HP fuel injection pump. In other words -- when you turn the ignition key to ON position -- this leeds to feed this SCV solenoid with 12V resulting the valve stem is being opened (lifted up by el magnetism criated in solenoid coil). Ini case of wise versa (ignition key is in OFF position)-- you take OFF 12V from this solenoid and the valve is being closed by a spring enabling the engine to be stopped. In case of solenoid coil fault or near to be burnt out -- you can feel jerky engine working.

The SCV is mounted on the HP (high pressure)fuel injection pump and fixed by two bolts (or screws). It's required to have SCV dismantled and to be applied multi tester to check with this coil circle + impedance. This impedance must be in value speciafied either in manual or in repair guide book. IN case of this coil fault -- it must be substituted on new one. Cheers/Igor

Link to comment
Share on other sites

Toyota dealer states it does not come separate, new HP Fuel pump is £800!!!

options

Parts from a breaker

can the solenoid/s be scavenged of another avensis and fitted easily? or is it easier to get a full fuel pump?

is it a job for dealer or any decent local garage?

cleaning

is this a DIY job? idiots guide?

Help!

Link to comment
Share on other sites


Toyota dealer states it does not come separate, new HP Fuel pump is £800!!!

options

Parts from a breaker

can the solenoid/s be scavenged of another avensis and fitted easily? or is it easier to get a full fuel pump?

is it a job for dealer or any decent local garage?

cleaning

is this a DIY job? idiots guide?

Help!

STOP !!!!

Paul

They try to have you made a fool. Both solenoids are normally two separate valves mounted on the HP pump body and can not be sold together with pump --- it is really greasy to follow this way. THey somply try to ear a lot of money -- do not believe them. I will urgently ask PArts King to help you. Besides -- try to locate demolition workshops --- these twos must be easily located. Part King will come back shortly.

Cheers/Igor

Link to comment
Share on other sites

Toyota dealer states it does not come separate, new HP Fuel pump is £800!!!

Nonsense!

A new pair of SCV valves are currently £236.85 retail, plus delivery

Kingo's price £207.08 INC Delivery

PM me to order

Kingo :thumbsup:

WELL DONE KING !!!

IGOR

Link to comment
Share on other sites

right, after a trip to Lindop it transpires that the fuel pump does NOT have SCV valves and is a model similar to a Hiace

The suggestion was that it might be the engine immobiliser (that attaches to the fuel pump) but it will require them to take it in do the tests etc

so the fault is still present, the symptoms are that the revs seem to either die from idle (can sometimes be caught, press accelerator and car keeps going) or the revs seems to fall very quickly when slowing and go to nothing

people at Lindop very nice and looked after me, but I'm still stuck with the problem

Link to comment
Share on other sites

Hi Paul can you tell me what tipe of engine you have ?

is your engine tipe 2AD?

if your engine is 2AD there my by have a rezolve of your problem

Hello nickyblueys1, sorry to butt in but according Pauls member details the car is a 2003/2004 d4d so i can assume it as a a 1CD 2.0 D4D engine. Please post your resolve for the 2AD d4d engine anyway as the information may be helpful to others on the forum :thumbsup:

Best regards .... Pete.

Link to comment
Share on other sites

anyone with a decent suggestion?

Hi Paul! Firstly i would like to say that i am very surprised to find that members on this forum, some with letters (Toyota technical qualifications) in front or after their name can't help you out here or even suggest a fix. Anyway moving on .... I would suggest you got hold of some Forte diesel additive (look on the net as it's trade only) or the Millers one locally and treat your car to a good dose of it along with some good fuel, i use Total Exellium. The above suggestion worked wonders in my sons high mileage Audi A6 2.5 tdi, it runs really smooth now with no more black smoke under load, more power and it ticks over great. He was actually recommended to add a full 400 ml bottle of Forte to 1/4 tank, which he did, then go with the recommended dose later (200ml per full tank), not that it needed it. I have worked on all sorts of vehicles but not on Toyota cars so i can't be more specific with help, now if i did work for Toyota i would surely be able to help you more. My car idles at 1100 rpm cold and 800rpm when hot, just a bit higher with the aircon on so yours seems to be in that range Paul. As for the revs dropping you may have an air leak on the induction side but i'm only guessing as the control systems these days are very complex so it could be down to a host of different things.

Don't get to down hearted mate as someone will come up with a suggestion. :thumbsup:

Best regards ..... Pete.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...




Forums


News


Membership