Jump to content
Do Not Sell My Personal Information


Vsc And Trc Off Light On


Nahim
 Share

Recommended Posts

Hey guys i know some other people have had this problem well when i was driving earlier all of a sudden my trc off and vsc light turned on and i dont know why this is. well it seems to have gone off after turning the engine off for a few mins but i dont know if i have a problem with the car and its worth taking to the garage :(

also on another note my MPG is pretty low at the mo my average is about 25mpg dont know if thats normal for you guys.

well i am hoping you guys can help

thanks in advance

Nahim

Link to comment
Share on other sites


Do you have a Typhoon fitted??

Sometimes that can cause it... altho when i first got my CTS the lights came on while i was driving but stopping and turning the engine off cleared them... not had them on since...

As for the MPG... mine has dropped too but that's because i have the heater on full in these cold mornings and i now sit in rush hour traffic :lol:

Link to comment
Share on other sites

Do you have a Typhoon fitted??

Sometimes that can cause it... altho when i first got my CTS the lights came on while i was driving but stopping and turning the engine off cleared them... not had them on since...

As for the MPG... mine has dropped too but that's because i have the heater on full in these cold mornings and i now sit in rush hour traffic :lol:

No just a K&N panel filter so i dont think it should be too much of a problem well i didnt think, could there be anything else that may set off this problem,

oh to add another prob that i have noticed on one of my brake disc i have noticed there are hair line cracks on them this may be a bit of a prob i think in terms of safety. do you think they are gonna need changing they are very small cracks next to my drilled holes

Thanks for your replies

Link to comment
Share on other sites

Do you have a Typhoon fitted??

Sometimes that can cause it... altho when i first got my CTS the lights came on while i was driving but stopping and turning the engine off cleared them... not had them on since...

As for the MPG... mine has dropped too but that's because i have the heater on full in these cold mornings and i now sit in rush hour traffic :lol:

No just a K&N panel filter so i dont think it should be too much of a problem well i didnt think, could there be anything else that may set off this problem,

oh to add another prob that i have noticed on one of my brake disc i have noticed there are hair line cracks on them this may be a bit of a prob i think in terms of safety. do you think they are gonna need changing they are very small cracks next to my drilled holes

Thanks for your replies

Would not take the risk with the discs pal, i would personally change them.

Link to comment
Share on other sites

i know i am fairly harsh on my brakes just cant afford to change them yet. i just havent had them that long tho.

oh i have called toyota they want me to bring the car in so they can look up the fault and charge me £55 i think,

what to do what to do lets just say im not friends with my car at the mo and it will not be getting a clean for a while lol

thanks for your help guys

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share





×
×
  • Create New...




Forums


News


Membership