Jump to content
Do Not Sell My Personal Information


New H/u Front Right Speaker Not Working


Wiilm
 Share

Recommended Posts

Avensis t3-s 2004

I replaced te factory h/u thanks to info posted here, but using the iso connector I bought, everything works o'k save for the front right speaker.(it was fine before using the factory stereo)

The h/u is fine, as is the speaker itself, because if I bypass the iso connector and connect the two grey front right speaker wires from the h/u directly to the speaker it works fine along with the other three Speakers.

There doesn't look to be any other correct wire colours to connect to on the avensis loom side of the plug and it is not the pins inside the iso plug itself because I bypassed the plug and tried connecting to the two wires on the loom side and the speaker still did not work.

Any ideas other than running a new cable to that speaker?

What colour wires should the avensis loom have for the front right? the diagrams I have seen say blue and green? but on mine one is orange and the other I forget. but it is not the orange for the Battery memory as memory works fine when that orange is not connected

Link to comment
Share on other sites


I don't see the Avensis listed on the installdr.com site.

Maybe American models use different color codes?

The wiring diagram looks very clear to me and it's the only thing I have.

I don't even own an Avensis (yet) so I can't go out and have a look either. :(

Sorry, for not being too helpfull.

Maybe someone else can shed some light on this.

Link to comment
Share on other sites

Avensis t3-s 2004

I replaced te factory h/u thanks to info posted here, but using the iso connector I bought, everything works o'k save for the front right speaker.(it was fine before using the factory stereo)

The h/u is fine, as is the speaker itself, because if I bypass the iso connector and connect the two grey front right speaker wires from the h/u directly to the speaker it works fine along with the other three speakers.

There doesn't look to be any other correct wire colours to connect to on the avensis loom side of the plug and it is not the pins inside the iso plug itself because I bypassed the plug and tried connecting to the two wires on the loom side and the speaker still did not work.

Any ideas other than running a new cable to that speaker?

What colour wires should the avensis loom have for the front right? the diagrams I have seen say blue and green? but on mine one is orange and the other I forget. but it is not the orange for the battery memory as memory works fine when that orange is not connected

Hi Wilm, here is a diagram in colour so this may help you out post-74463-1262199958_thumb.png

Best regards and all the best from Pete.

Link to comment
Share on other sites


I didn't get how you by-passed the iso-cable. It sounds like the fault is a cable. It could be the iso-cable as it was working when by-passing the iso-cable, or the original green/blue cables to the speaker.

Link to comment
Share on other sites

  • 9 months later...

Sorry for belated reply I was abroad at the time in a country with limited internet access and other resources.

Thanks for wiring link and yes I guess iso connector was at fault.(should have fitted it before I set out abroad, but had no time) I fixed it with a bodge that consisted of disconnecting relevant wires out of HU from iso and connecting them directly to a cable that I ran along inside of lower dash and out through car body grommet and in through driver door grommet.I forced the cable through pinpoint holes that are so tight they selfseal.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share





×
×
  • Create New...




Forums


News


Membership