Jump to content
Do Not Sell My Personal Information


05 Rolla 1.4d4d T3 Hanging Round 3krpm During Acceleration


Recommended Posts

It happened to me quite a few times but it's really tideous.. I never caught up a pattern but I couldn't not notice that whenever I floor it, it accelerates sharply to 3krpm, hangs there for half a second and then continues its journey up.. Any ideas? Car was always serviced every 6months and is due for her next service this week for oil + inspection. I hope it's not related to the MAF or something expensive of the sort.

Link to comment
Share on other sites

Sounds like a blocked or failing EGR valve, i have had this problem on other cars. Have a look at Rick D4D'd thread in the Auris section for some info. I would look at this before anything else.

Link to comment
Share on other sites

Sounds like a blocked or failing EGR valve, i have had this problem on other cars. Have a look at Rick D4D'd thread in the Auris section for some info. I would look at this before anything else.

Ok Someone can help out with the Rolla's 1.4D4D EGR Valve inspection / removal ?

Link to comment
Share on other sites

Sorry, i have never looked under the bonnet of a 1.4 D4D, why not ask your garage to point it out and advise on removal then follow the existing guide to cleaning? Or you could ask them to do it, if your willing to pay for 0.5-1 hrs labour.

Link to comment
Share on other sites

Sorry, i have never looked under the bonnet of a 1.4 D4D, why not ask your garage to point it out and advise on removal then follow the existing guide to cleaning? Or you could ask them to do it, if your willing to pay for 0.5-1 hrs labour.

Would prefer to do it myself though..anyone can identify some helpful links or what I should look at ?

Link to comment
Share on other sites

Take me some pictures of you engine front and back sides of hte block from above (engine cover off) should be able to guide you from there as long as its not massively different fro ma typical setup

Link to comment
Share on other sites

Take me some pictures of you engine front and back sides of hte block from above (engine cover off) should be able to guide you from there as long as its not massively different fro ma typical setup

While taking a look at this thread http://toyotaownersclub.com/forums/index.p...106241&st=0 I noticed similarities with my engine so this should pretty do it..I'll give it a try during the weekend since the symptoms are pretty much the same aswell so the egr should be the culprit. Big Thanks fir Cabcurtains for pointing it out. Will let u know............

Link to comment
Share on other sites

Take me some pictures of you engine front and back sides of hte block from above (engine cover off) should be able to guide you from there as long as its not massively different fro ma typical setup

While taking a look at this thread http://toyotaownersclub.com/forums/index.p...106241&st=0 I noticed similarities with my engine so this should pretty do it..I'll give it a try during the weekend since the symptoms are pretty much the same aswell so the egr should be the culprit. Big Thanks fir Cabcurtains for pointing it out. Will let u know............

Good Luck :thumbsup:

Link to comment
Share on other sites

waw, that looks like a pretty good link, my mpgs have droped big time in the last 4 months, and iav noticed lag which wouldnt be turbo lag, so might be worth giving it a go,

lad if you do this before me will you take pics to make my job handier please :P

oh and post up your before and after mpgs :thumbsup:

Link to comment
Share on other sites

Well, also noticed that sometimes i feel a "dip" about 2800rpm...

What part should i take off to clean, so where's the manifold and the egr valve? :D

foto0042hk.jpg

Link to comment
Share on other sites

Well, also noticed that sometimes i feel a "dip" about 2800rpm...

What part should i take off to clean, so where's the manifold and the egr valve? :D

foto0042hk.jpg

I circled the likely location of the EGR valve...I've been searching for that kind of shot since I was too lazy to take a shot of mine :P I'll be doing the thing during the weekened since now I'm averaging a poor 43.7MPG, but no black smoke.

Link to comment
Share on other sites

Well, also noticed that sometimes i feel a "dip" about 2800rpm...

What part should i take off to clean, so where's the manifold and the egr valve? :D

foto0042hk.jpg

I circled the likely location of the EGR valve...I've been searching for that kind of shot since I was too lazy to take a shot of mine :P I'll be doing the thing during the weekened since now I'm averaging a poor 43.7MPG, but no black smoke.

is that 43 mpg on your display or have you done the calculations, iav down to 48mpg, although last fill was only 45mpg, so iam really not happy, i always averaged 56mpg so its a big drop, let us know how you get on

Link to comment
Share on other sites

Well, also noticed that sometimes i feel a "dip" about 2800rpm...

What part should i take off to clean, so where's the manifold and the egr valve? :D

foto0042hk.jpg

I circled the likely location of the EGR valve...I've been searching for that kind of shot since I was too lazy to take a shot of mine :P I'll be doing the thing during the weekened since now I'm averaging a poor 43.7MPG, but no black smoke.

is that 43 mpg on your display or have you done the calculations, iav down to 48mpg, although last fill was only 45mpg, so iam really not happy, i always averaged 56mpg so its a big drop, let us know how you get on

Yes 43 is the average indicated on my display. However I drive a lot in traffic and its a continous start-stop situation, so mpg suffers alot. No highways unfortunately :(

Link to comment
Share on other sites

However I drive a lot in traffic and its a continous start-stop situation, so mpg suffers alot. No highways unfortunately :(

This type of usage causes the EGR valve to clog quickly which could explain the issue :)

Link to comment
Share on other sites

However I drive a lot in traffic and its a continous start-stop situation, so mpg suffers alot. No highways unfortunately :(

This type of usage causes the EGR valve to clog quickly which could explain the issue :)

Ok guyz I got it :D

I cleaned the valve during the weekend and it's pulling smoothly through all gears. Here's the how to for the 1.4 D4D '05...

1. Remove the engine cover, this just pulls up and unclips.

DSC00023.jpg

2. Start taking off the radiator by these 2 bolts (you'll have to tap the radiator's fluid passageway)

DSC00021.jpg

3. Then onto the other end, where it gets tricky..especially the bolt opposite the one near the Dipstick.

DSC00020.jpg

4. Remove the Dipstick and Black cabling trunking bolts off to gain access to the bolt still holding the radiator to the egr

DSC00019.jpg

DSC00018.jpg

5. And then it's off

DSC00017.jpg

6.Notice the dirty egr opening with black soot

DSC00016.jpg

7. and blocked airway to the manifold

DSC00014.jpg

8. Clean the soot with a screwdriver or something and get it out of the passageway as much as you can..and give it a good clean with Carb-cleaner and a piece of cloth till it shines....this way

DSC00013.jpg

DSC00010.jpg

DSC00005.jpg

9. and everything back in one piece..you can re-use the same gaskets. You'll surely notice that the engine won't start due to the excess of carb cleaner which has now been gulped by the engine, just give it a crank or two and you'll get it back to life in a jiffy, not without a huge cloud of vapour of the unburnt carb cleaner. It will take a couple of engine starts before it starts firing up as it used to.

10. Now engine is much more willing to pull through all gears and even through low rpms..Mpg has start climbing again :)

The fine-print

Obviously this is not for the faint hearted, but for those willing to save a buck or two it's worth a try. Users can use this as a reference and cannot copy the content to other sites. Obviously it's your responsibility to use this post wisely, thus I cannot be held liable for any damage to your engine/vehicle in any way.

Link to comment
Share on other sites

thanks for that, i started routing with it last night alright but gave up cause it was too cold, must try it the weekend, my mpg has gone down the drain lately, hope this fixes my problem, what were you getting and what are you getting now ?

Link to comment
Share on other sites

Well, i had the problem that (especially in 2nd gear) the rolla hanged at 2800rpm, when accelerating hard.

So it was very easy for me to notice any difference, the "dip" at 2800rpm has gone now :thumbsup:

Link to comment
Share on other sites

did 5 mile and seen the mpg flying up :yahoo:

and a downside, after 10 mile i turned the car off, started back up on now the engine management light is on so iam not a happy camper, in to Mr.T in morning :crybaby:

Till now I saw a 15% increase in mileage. Are you sure you plugged back all the connections back to their place?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share





×
×
  • Create New...




Forums


News


Membership