Jump to content
Do Not Sell My Personal Information


Problem With Wipers


blutto
 Share

Recommended Posts

My wipers are not self canceling, single wipe (push up)only works whilst pushed up soon as I release,they stop regardless of where they are, on auto (rain sensing) they stop on the return wipe at "ten to" and then stagger the rest of the way.

Wipers work perfect on normal and fast speed and self cancel as they should, been told I need a new motor, but do you think its a relay problem or is it all self contained within the motor, hence new one.

£290 fitted by mr T.

Link to comment
Share on other sites


As I think I said to Colin when he was down for Pod, there are certain situation in which mine will stop the wipers mid screen. But its not as defined as Colins and more of a 'once in a blue moon' thing.

Go with Gaz's idea, replacement from a poorly CTS. Fortunately wiper motors are that big a !Removed! to swap out if you do go down the breakers part route :)

Link to comment
Share on other sites


just a arrived in dumfries scotland rained most of the way, no probs with wipers at all. I dont think its the motor, seems to hapen when screen is almost dry 'ie' just spray. But as i said no probs at all today very strange.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...




Forums


News


Membership