Jump to content
Do Not Sell My Personal Information


Any High Mileage T Sport Out There?


SF695
 Share

Recommended Posts

Have seen a couple of T sport for sale, not sure if they are any more. Just wondering how they do over time and mileage.

Link to comment
Share on other sites


Have seen a couple of T sport for sale, not sure if they are any more. Just wondering how they do over time and mileage.

the heater matrix seems to get blocked after a few years . my first clutch is starting to wear out on 72,000 miles . some people are getting rusted exhausts which are easily repaired .

Link to comment
Share on other sites

How about the engine. Read something about the oil pump being the weak spot, but except from that, any serious issue over time and mileage?

Link to comment
Share on other sites

Just done my 110K (miles) service today, 04 plate.

To be honest, since I managed to get all the wrongs the car came out the factory with put right, the only bother I've had is with the alarm going off randomly, oh, and the heater switch will not turn on the fan when it's winter - I have to press the windscreen button then change mode.

Clutch was last done just before warranty ran out on around 40k, still going strong, replaced weak Battery last October. Still running on original exhaust and dampers. It flew through the last MoT in February with an advisory for tyres which I was getting 4 off fitted right after the test anyway.

I thrash the car every time I drive it - which is every day - within the scope of the law.

Nothing major so far...

Link to comment
Share on other sites

Just done my 110K (miles) service today, 04 plate.

To be honest, since I managed to get all the wrongs the car came out the factory with put right, the only bother I've had is with the alarm going off randomly, oh, and the heater switch will not turn on the fan when it's winter - I have to press the windscreen button then change mode.

Clutch was last done just before warranty ran out on around 40k, still going strong, replaced weak battery last October. Still running on original exhaust and dampers. It flew through the last MoT in February with an advisory for tyres which I was getting 4 off fitted right after the test anyway.

I thrash the car every time I drive it - which is every day - within the scope of the law.

Nothing major so far...

Did the clutch need changing, or did you do it just in case? And what wrongs are we talking about from factory?

Link to comment
Share on other sites

Toyota reckoned it needed doing, which surprised me as I had not long parted with Mk2 Golf with 280k on the clock that hadn't had a clutch in 10 years, anyway I made sure I got the old plate back and found it would've still been good for a few tens of thousands of miles. Basically they must've been hard up at the time and obviously desperate for my £75 to keep the dealership alfoat.

The factory fitted faults really amounted to a duff computer. Dingles of Norwich where I bought the motor tried to fob me off with mats and stuff, but having lashed out 10k I wasn't about to let them off with it. They even admitted the faulty computer and put new tyres on saying that would fix it. I suggested they send that particular service manager for retraining - new rubber to cure an electronic fault indeed..!

That dragged on for soo long (bit like this post) it felt like there was always a problem, but with a week to spare on warranty another dealer replaced the unit for me. As well as a heater louvre that was beginning to fall out.

It has the common dashboard fault, with the radio sitting proud. And always has rattles and squeaks from somewhere on the dash.

Otherwise, it keeps going.

Link to comment
Share on other sites

Just done my 110K (miles) service today, 04 plate.

To be honest, since I managed to get all the wrongs the car came out the factory with put right, the only bother I've had is with the alarm going off randomly, oh, and the heater switch will not turn on the fan when it's winter - I have to press the windscreen button then change mode.

Clutch was last done just before warranty ran out on around 40k, still going strong, replaced weak battery last October. Still running on original exhaust and dampers. It flew through the last MoT in February with an advisory for tyres which I was getting 4 off fitted right after the test anyway.

I thrash the car every time I drive it - which is every day - within the scope of the law.

Nothing major so far...

Have you changed your lift bolts?

Link to comment
Share on other sites

i bought my t-sport in feb 2009 and the milage was on 58000, i have still got the car and is now on 86000. in the time of owning the car i have changed the discs and pads on the rear once, the pads on the front once, an o/s/r brake caliper and thats it apart from the obvious tyres which i put a set of toyos on when i first bought it and now run federal "ditch finders"

i would definatly recommend one of these cars to any one as i think most people who own one would, in my opinion a very good looking underestimated car that are bulletproof "touch wood"

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...




Forums


News


Membership