Sign in to follow this  
shoey100

Intermitent Power Lose Under 2000 Rpm

Recommended Posts

need help ive had this problem since owned it was intermitent at first now more offten no error codes recorded local garage thinks its air flowmetre ..its now doing me head in ...any help please

Share this post


Link to post
Share on other sites

need help ive had this problem since owned it was intermitent at first now more offten no error codes recorded local garage thinks its air flowmetre ..its now doing me head in ...any help please

hello

clean both MAF and trottle first + check again.

Cheers/Igor

Share this post


Link to post
Share on other sites

need help ive had this problem since owned it was intermitent at first now more offten no error codes recorded local garage thinks its air flowmetre ..its now doing me head in ...any help please

hello

clean both MAF and trottle first + check again.

Cheers/Igor

Share this post


Link to post
Share on other sites

hi thanks for that info mate but could explain what it intails. many thanks...igor..

Share this post


Link to post
Share on other sites

Easy to do.

1. Remove the hose connection from air filter to throttle body

2. The MAF sensor is that black unit on top of the air filter housing, remove the connector, bring out and clean

3. Get carburettor cleaner and spray to clean the throttle body and IACV.

Reconnect back in the reverse orders.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this