Sign in to follow this  
aygokid

Failed My M.o.t (Help)

Recommended Posts

right, it was the aygos first m.o.t today, went to pick it up and he said its failed, i asked what on he sed its giving wayyyy too high emisions, ive had a performance backbox fitted but thats not the fault he sed, he sed it could be a sensor :S:S what do yu guys reckon ? stuck with no car now

Share this post


Link to post
Share on other sites

Sorry to hear that on such a young car... crybaby.gif

Share this post


Link to post
Share on other sites

right, it was the aygos first m.o.t today, went to pick it up and he said its failed, i asked what on he sed its giving wayyyy too high emisions, ive had a performance backbox fitted but thats not the fault he sed, he sed it could be a sensor :S:S what do yu guys reckon ? stuck with no car now

The MOT tester should have given you a fail sheet listing the reason for failure and the figures. Can you post these, they may help someone understand what sensor failed.

Just a thought, when did you last change your air filter? Could be a choked filter.

Share this post


Link to post
Share on other sites

Choked filter sounds plausible, or a failed or failing O2-sensor, but that would

usually be noticed by the ECU I'd think and it would put on the Check Engine light...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this