Sign in to follow this  
AndyG80

Engine Management Light

Recommended Posts

Hi All,

This is my first post, I have a problem with my Celica, Its an '02 plate and done 92k miles, just recently the engine management light has been coming on when i accelerate over 6000RPM, I thought it may be air filter sensor and cleaned that, removed Battery and the light went away. Last night i tested it and the light came back on and i have noticed also that it does not give you that extra 'kick' that it used to now either,

does anyone have any ideas/suggestions

Thanks in advance

Andy

Share this post


Link to post
Share on other sites

could be that the lift bolts have snapped.????

Share this post


Link to post
Share on other sites

could be that the lift bolts have snapped.????

Thanks, i will check that first and see if it is that

Andy

Share this post


Link to post
Share on other sites

your management light is on so get a diagnostic check carried out, see what fault code is been triggered, you should be able to work it out from there.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this