Sign in to follow this  
phoenixz

Wierd Problem

Recommended Posts

today i noticed a strange smell on one side of my car, smelled like a wet dog. it's only outside the car and is strongest near the wheel arches. at first i thought i had run over something that had left its trace. however, about 20 minutes after, the car started making a funny noise at about 3000 revs.

it has continued for the rest of the night(i work delivering pizzas) and it no longer feels as though the supercharger is kicking in (it's the T-sport compressor i drive).

i have searched online and had all suggestions from its a leak, or mold in the air filter, or just needs a wash. only one suggestion seems to cause all of the symptoms... i have a mouse in the engine. this may sound silly but i live next to a field and not far from a farm, my house often gets mice in the loft and iv already had a mouse make a nest in my fibre glass Ginetta G28.

i was wondering if anyone here had any suggestions or theories before i tear apart the engine looking for a rodent.

anything would be helpful.

Phoenixz

P.S. i know what some of you will be thinking about my using a sport compressor for doing pizza deliveries, but i couldn't think of a better car to do it in :P

Share this post


Link to post
Share on other sites

well where could the mouse have got in? i can only think of cold air intake pipe and/or the fresh air intake pipe for the heating/cooling system in the cabin, check both these see if you can find anything.

Share this post


Link to post
Share on other sites

Very unlikely but an Obstruction on the air intake could explain the lack of power you are experiencing, & the smell could mean that the obstruction could be a small animal. Goodluck with the investigation though :thumbsup:

Share this post


Link to post
Share on other sites

make sure you haven,t got a brake sticking on which would smell and give you a lack of power also if clutch is slipping gives a real bad smell and loss of power .check them . :thumbsup:

Share this post


Link to post
Share on other sites

ok, thanks for all the good suggestions, but i'm afraid none of you have managed to win the prize. :P

turns out the Cat is breaking apart :( it may have been caused by some over exuberant driving, but it has left me in a right spot. the exhaust system seems to be all in one so replacing the Cat is going to be expensive. the smell was from the Cat and the rattling has become progressively louder as it breaks apart further. the mechanic didn't take it apart to look, but he thinks that something has broken off and become stuck (hence the loss in power).

my plan is to get a custom Decat pipe made and check the omission levels on the current broken Cat. if they are still below the legal level then i'll keep the broken Cat and just switch it every time i go for an MOT.

if anyone has a Cat for sale or even a Decated pipe for a compressor then i'd very much be interested in purchasing it.

Phoenixz

P.S. mice only need a hole the width of a pencil to get into any place and they can chew through most things, but i no longer think that a mouse has caused this

Share this post


Link to post
Share on other sites

Would you describe the smell as a sort of rotten eggs aswel as wet dogs?

Share this post


Link to post
Share on other sites

Perhaps the cat is breaking appart as it is tired of chasing the mouse :lol:

Sorry couldn't resist.

Hope you get it sorted.

Share this post


Link to post
Share on other sites

well, it appears that detting it decatted is a no go. the compressor has an all in one exhaust system so i may have to replace the whole thing. it appears that the catalytic converter costs about £240 on its own. i'm not sure if i'll be able to replace just the Cat, but if i have to replace the whole system then it's gona cost £940 just for the parts.

it turns out that the cause of this breaking Cat has been slow driving. i bought the 5 year old car with 18,000 miles on the clock about 6 months ago. it appears that it had barely been used at all, which has led to the Cat becoming cold and brittle. since i have owned the car i have been driving it roughly now and again, which has put strain on the cat causing it to break apart. never thought that low mileage on a car would be a bad thing.

yes there was a smell of rotten eggs a couple of days ago

Phoenixz

Share this post


Link to post
Share on other sites

well, it appears that detting it decatted is a no go. the compressor has an all in one exhaust system so i may have to replace the whole thing. it appears that the catalytic converter costs about £240 on its own. i'm not sure if i'll be able to replace just the Cat, but if i have to replace the whole system then it's gona cost £940 just for the parts.

it turns out that the cause of this breaking Cat has been slow driving. i bought the 5 year old car with 18,000 miles on the clock about 6 months ago. it appears that it had barely been used at all, which has led to the Cat becoming cold and brittle. since i have owned the car i have been driving it roughly now and again, which has put strain on the cat causing it to break apart. never thought that low mileage on a car would be a bad thing.

yes there was a smell of rotten eggs a couple of days ago

Phoenixz

WHATS THE REG ON YOUR COMPRESSOR i will take a guess at **56 yav if so i know what's caused it.

Share this post


Link to post
Share on other sites

it's not, but i'd be interested to hear what you've got to say anyway.

Phoenixz

Share this post


Link to post
Share on other sites

it's not, but i'd be interested to hear what you've got to say anyway.

Phoenixz

I BET IT WAS RUN ON NORMAL UNLEADED FOR A WHILE as my last compressor was traded in to a dealer who used it for 6,0000mls before selling it and never put 98 ron in it,was just a thought.

Share this post


Link to post
Share on other sites

it's not, but i'd be interested to hear what you've got to say anyway.

Phoenixz

I BET IT WAS RUN ON NORMAL UNLEADED FOR A WHILE as my last compressor was traded in to a dealer who used it for 6,0000mls before selling it and never put 98 ron in it,was just a thought.

i can believe that, and it's a good thought, iv only put 98+ ron petrol in since i got it and that may have caused a problem. if its a suddenly gone from cheap, slow and dirty petrol to clean and fast use.

u really can't tell what the owner before you was putting in your car.

Phoenixz

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this