Jump to content
Do Not Sell My Personal Information


Need Help Asap!


BigDougz
 Share

Recommended Posts

I have a 1998 1.6 16V Corolla ......i put a new Battery in today as the old one was done....... she started ok and is charging 100% but my problrm is when i turn on the lights for a wile , when the cars running and i turn it off, the Battery goes kinda dead and the car wont start as its not turning over fast enough..... but leave it f$or a will and it starts again...i was thinking the starter could be ceased abit or there is sometinh draining the Battery ... help please it only my new car...

Link to comment
Share on other sites


Check battery connections,any underbonnet earth connections,alternator drive belt isn't slack or perished.Also,check it isn't a ignition switch fault.Does the engine turn over or do you just get a click from the starter solenoid?

checked all them she...turns over wile slow but leave it for a wile and she will start

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share





×
×
  • Create New...




Forums


News


Membership