Sign in to follow this  
three5

Oil Maintenance Warning Light ( 4.3 Xt5 D-4D )

Recommended Posts

Hi all,

has anyone had an "Oil Maintenance required now" ( paraphrased ) warning come up on the dash? The car has done just over 20k miles an has had Oil changes at 5, 10 and 16k, the last one in April as part of the 2nd ( year ) dealer service. Driving down the A19 yesterday and the warning light came on. Heart attack country this, as the motor is looked after better than the wife! Dealer says the light is connected to the odometer and thinks it needs a 20k service. They have asked me to take it in to them to fix and indicated that it would only take a minute - just a question of pressing buttons/switches in the right order. As it is a 70 mile round trip and I'm up to my kneck in work at the moment I'd be quite happy to turn the thing off myself if I could find out how. Needless to say, the Oil is within about 3mm of the top mark on the dipstick. Any advice gratefully received! :unsure:

Share this post


Link to post
Share on other sites

Yeah, well, probably they should have reset it @ service.

Set the multi-information display to TRIP A.

Turn the ignition switch off.

Press and hold the ODO / TRIP switch, and turn the ignition switch on (IG).

After turning the ignition switch on (IG), keep holding the switch for at least 5 seconds.

Share this post


Link to post
Share on other sites

Yeah, well, probably they should have reset it @ service.

Set the multi-information display to TRIP A.

Turn the ignition switch off.

Press and hold the ODO / TRIP switch, and turn the ignition switch on (IG).

After turning the ignition switch on (IG), keep holding the switch for at least 5 seconds.

Thanks SHCM - I was keeping my fingers :thumbsup: crossed that you might look in. I owe you one fella - saved me half the morning tomorrow! MANY THANKS.

Share this post


Link to post
Share on other sites

Yeah, well, probably they should have reset it @ service.

Set the multi-information display to TRIP A.

Turn the ignition switch off.

Press and hold the ODO / TRIP switch, and turn the ignition switch on (IG).

After turning the ignition switch on (IG), keep holding the switch for at least 5 seconds.

Thanks SHCM - I was keeping my fingers :thumbsup: crossed that you might look in. I owe you one fella - saved me half the morning tomorrow! MANY THANKS.

All done and dusted! Thanks again SHCM :thumbsup:

Share this post


Link to post
Share on other sites

All done and dusted! Thanks again SHCM :thumbsup:

:thumbsup:

Share this post


Link to post
Share on other sites

Mine has just popped up with this too. I have only had the car 5 months and done 4k miles. The garage assured me that they serviced it before it was given to me but now I am not too sure. After all, it was Arnold Clark...

Is there any way to find out?

Share this post


Link to post
Share on other sites

Any dealer will know if it has been done and your record should show it too. The fact that the light has come on is no surprise as you only get a "semi-skilled" youth changing your Oil at the dealer. The clever lads are busy breaking far more expensive things. It still costs £90+VAT an hour whoever forgets to do it. I must admit my dealer is good but they have a very good service manager keeping an eye on things.

Just re-set the Oil light and don't worry! Best solution is to do it yourself next time!!!

Share this post


Link to post
Share on other sites

you only get a "semi-skilled" youth changing your oil at the dealer.

You learn something new everyday, I thought they used monkeys :D

Share this post


Link to post
Share on other sites

All done thanks. Love the little countdown you get before you can release the odo button!

Share this post


Link to post
Share on other sites

Talking of Arnold Clark. My bro in law bought his Rav from them. He rang me yesterday saying it threw the coolent. He popped into the Toyota Garage and they confirmed it was the head gasket. However they said as it was reported last year it will be covered by warranty. My bro in law said it wasnt reported. They confirmed that AC had rang to ask about the head gasket but dident proceed. Seems they must have decided to try and fix it themselves then sell it on. It lasted a year. toyota now replacing it and doing it properly

Share this post


Link to post
Share on other sites

Sorry to hijack this thread many, many months later but you've all saved me a trip to the dealers.

The light came on 2 months after a 50K service Oil on top level, reset no problem.

Many thanks

Gaz

  • Like 1

Share this post


Link to post
Share on other sites

We do some useful stuff between the larking about. On occasions we find threads where we left them if we are lucky ;-)

  • Like 1

Share this post


Link to post
Share on other sites

thanks for as regards reseting Oil maint light, you probably saved me the usual bundle of dosh at my local toyota dealership

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this