Sign in to follow this  
Big E

Gen 6 St202 Red Oil Light Comes On

Recommended Posts

Hi All,

Has anybody had this problem. When driving the car the Oil light stays off.... When sat in traffic

my RED Oil light comes on...I do have Oil in...

Has this happened to anyone... Is it the Oil pressure switch or the Oil pump...???

Any advice or help would be good...

Many thanks in advance

Big E

Share this post


Link to post
Share on other sites

Hi All,

Has anybody had this problem. When driving the car the oil light stays off.... When sat in traffic

my RED oil light comes on...I do have oil in...

Has this happened to anyone... Is it the oil pressure switch or the oil pump...???

Any advice or help would be good...

Many thanks in advance

Big E

Had a good poke around and a clean up...but could find nothing but when everythings been put back together the light is out... I checked the bulb (just in case) and thats fine.... So totally unsure what happened and what was up but its ok now.... (fingers crossed)...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this