Sign in to follow this  
martyn84

Ticking Noise With Revs

Recommended Posts

Hi i have a yaris 1999 1.1 , problem is with the digital speedo when i turn the car on i have a ticking noise from the speedo, and when i increase the revs the noise increases Ive done a video of it and hope you can help me with the problem. i have unplugged the speedo and the noise stops so i know thats the problem. anyway will i be able to fix this or will i have to get a new one

Regards

Martyn

Share this post


Link to post
Share on other sites

Hi and welcome to TOC.

Have you tried this with the CD player off?

Share this post


Link to post
Share on other sites

I don't have the car at the min will have it back at 12. but how could the CD players cause this?. the noise increases with revs. also if i jockey the steering wheel from left to right it does it. so when i unplugged the speedo it stopped. you see the black box which is attached to the speedo? its coming from in there.

Regards

And thanks for the welcome

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this