Sign in to follow this  
4A-GE TRD

20V Silvertop Conversion Problem

Recommended Posts

hi toy peeps i got a 20v conversion in my ae-92 i recently got a piston failure or so i think..my 3rd cylinder..spark plug is wet..changed plugs around either way it still get wet at 3rd, changed all plug leads there is current running through..the other thing is theres Oil coming out the 3rd throttle too! And its blowing out air instead of sucking..note.car does not smoke..could it be the Oil rings? Help plz

Share this post


Link to post
Share on other sites

Could you explain the second part cos i dont under stand what you mean.

Wet spark plug could be unburnt fuel you could have a misfire,

Share this post


Link to post
Share on other sites

sounds like serious piston issues to be fair but to confirm is the plug wet with Oil or fuel?

if its fuel it could be a coilpack or lead fault, if its Oil its FUBAR

Share this post


Link to post
Share on other sites

That's nasty! If it's water then I am surprised it's not bent the rods... maybe the gasket has gone?

If there is Oil coming out I would expect the rings to have gone, plus if the spark plugs are coated in fuel then your injector id either mistimed or dumping it in there... as Dawesy said, coil packs.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this