Sign in to follow this  
NAM8123

How To Connect Replacement Hu To Factory Subwoofer?

Recommended Posts

Hi, I've also posted this on the Celica forum.

New owner here! Just got a 2005 Celica VVTI with the premium and style pack, so it has the active sub woofer in the boot. I've just replaced the factory HU, the new Pioneer one connected fine with ISO adapters, but the active sub can't connect as the HU only has phono connectors available on the back. Although the HU sounds fine it would be good to get the sub working.

Has anyone else fitted an aftermarket HU and found a way of connecting to the sub without cutting the wiring loom ie does a phono to wiring block adapter exist? If not and the looms has to be spliced, what is the wire decode for the sub.

Look forward to your help on this one.

:thumbsup:

Share this post


Link to post
Share on other sites

man-bing,

Thanks, Caraudio direct are near me in Wallingford so I'll give them a ring!

Share this post


Link to post
Share on other sites

Hi,

I know this post is quite old now, however I have the same issue, did you manage to find a solution to this problem?

Thanks

Rishi

Share this post


Link to post
Share on other sites
however I have the same issue, did you manage to find a solution to this problem?

This was my solution to the prob, have a look and see if it helps you too

Speaker to RCA (Phono) Converter

Bing

:thumbsup:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this