Sign in to follow this  
richard price

Strange Noise

Recommended Posts

Hi - On turning off the ignition I get a 2 second rushing noise with a slight screech that I am sure is from the Speakers it happenes if the engine has been running or you just turn the ignition off without starting the engine, the radio can either be off or on it happens. All electrics are woring fine and there is no difference in the way it drives. Any body had a similar problem??. Thank you. :unsure:

Share this post


Link to post
Share on other sites

Make sure the heater is switched right off and try again :thumbsup:

Share this post


Link to post
Share on other sites

I get the same with a Renault Midlum. A thump on the radio fixes it!

Share this post


Link to post
Share on other sites

Make sure the heater is switched right off and try again :thumbsup:

Tried that yesterd after a 20 mile run to work, it made no difference, so I tried a number of combinations ie leaving things on and turning off, again no difference. After the return journey home it did not make a noise, spookey. C what happens today. :drool:

Share this post


Link to post
Share on other sites

Make sure the heater is switched right off and try again :thumbsup:

Tried that yesterd after a 20 mile run to work, it made no difference, so I tried a number of combinations ie leaving things on and turning off, again no difference. After the return journey home it did not make a noise, spookey. C what happens today. :drool:

Hi - Its started to make the noise again. Any more ideas please. :help:

Share this post


Link to post
Share on other sites

The aircon makes some funny noises when it shuts down. Are you sure it isn't that? Try to record it and give us a sound clip. Is your recirculation button pressed. Also, the headlights sometimes cycle through the height adjustment when you switch the ignition off.

Share this post


Link to post
Share on other sites

The aircon makes some funny noises when it shuts down. Are you sure it isn't that? Try to record it and give us a sound clip. Is your recirculation button pressed. Also, the headlights sometimes cycle through the height adjustment when you switch the ignition off.

Anchorman - Thank you I will get the computer literate to sort that one hopefully this weekend. :thumbsup:

Share this post


Link to post
Share on other sites

I get something vaguely similar but its to do with the intercooler pump and cooling fans trying to cool down the number 1 beast after a good run.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this