Sign in to follow this  
jerry hart

Electrical Fault

Recommended Posts

Hi I have a problem with my Landcruiser HDJ100, it blew a number of fuses blew whilst disconnecting towing light cable,all seem to have been replaced however the reversing lights have stayed on. THe remaining problem is that the car drives ok but as soon as the lights are turned on it looses power almost as if if has changed down a gear. If the lights are turned on whilst the vehicle is in motion it immediately drops down again.

Can anyone give me some suggestions

Jerry Hart

Share this post


Link to post
Share on other sites

Sounds like you have some kind of short circuit in the trailer wiring, possibly from damage or burnt out wiring. Be prepard to spent a couple of hours with a multimeter and pen and paper to find it.

Consider:

Removing fuses until the fault goes away (you didn't put larger fuses in after they blew did you?)

Unplugging items until the fault goes away

Measuring resistances to GND on the suspect trailer harness.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this