Sign in to follow this  
Hodgy766

Need Help With My Vigo

Recommended Posts

I live on the Island of Barbados. I own a Hilux Vigo 3.0 TDI 2006. When I push on the pedal for it to go it just does absolutely nothing until it reaches to 1800 RPm when the Turbo cuts in and at that point the trucks works beautifully! While on the highway I have to select D3 so as not all the RPm to drop below 2000 cause it just feels lifeless. I had the vehicle fully serviced but its still doing it. Our local Toyota dealer put it on a diagnostic but so far the problem cant be located. Does anyone have any suggestions? Its difficult to explain.. From Idle to the turbo point the trucks feels as tho is surging. Almost like its trying to go but cant. Any suggestions please will be appreciated.

Allan

Share this post


Link to post
Share on other sites

welcome to the forum. Story of my life ---- I have trouble surging as well but might be my age. tryt posting in the section for Hilux ??? good luck.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this