Jump to content
Do Not Sell My Personal Information


:-( Help Please


Recommended Posts

hi all,

I have had 3 warning lights appear on my dash. Traction Control, Vechile Stability Control & Engine Management Light. I have heard that this can be caused by the secondry air pump going faulty, could anyone shed any light on this for me please. Thanks a lot

Link to comment
Share on other sites


It could be caused by many errors dude. You need a code reader to check the exact pinpoint of where the fault lies unfortunately?

Just out of curiosity!! Have you fitted an induction kit?? If so which one?

Link to comment
Share on other sites

It could be caused by many errors dude. You need a code reader to check the exact pinpoint of where the fault lies unfortunately?

Just out of curiosity!! Have you fitted an induction kit?? If so which one?

Nope not fitted an Induction kit as yet, was thinking of a K&N tho, I am open to suggestions as to what one is best value for money ????

Link to comment
Share on other sites

On the way to the cinema this evening whilst driving conservatively keeping revs low etc. I encountered some warning lights. I got traction control, vehicle stability and abs. After the film jumped in and it was fine?! You might be lucky. Otherwise the code reader is the way forward!

Good luck pal.

Link to comment
Share on other sites

Well 1st reset your ecu. Either by pulling the two 15amps next to each other in the fuse box under the hood. Or by removing negative off Battery for around 10 minutes.

It should remove the lights until the problem arises again or remove them for good until you get another error. If the lights remain after ecu reset then you you know something's up and the only you'll find out is via a ecu reader.

Can't be anymore help I'm afraid!! Good luck :thumbsup:

Link to comment
Share on other sites

  • 7 months later...

hi all,

I have had 3 warning lights appear on my dash. Traction Control, Vechile Stability Control & Engine Management Light. I have heard that this can be caused by the secondry air pump going faulty, could anyone shed any light on this for me please. Thanks a lot

Hello

Did you have any luck with this? Mine did it before and then stopped once I switched the engine on and off. THese 3 lights came on yesterday and wont go back off. Did you get yours fixed?

Do I need to take it to a Toyota garage to get it diagnosed? I dont know about such matters.

Also, can it be connected to the fact I need to discs and pads in the rear?

Cheers

Del

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share





×
×
  • Create New...




Forums


News


Membership