Jump to content
Do Not Sell My Personal Information


Maf Woes


chris1712
 Share

Recommended Posts

Hi guys, I've fallen victim to the fairly common problem caused by the typhoons positioning.

IMAG0019.jpg

It's just the wire from the connector, but the connector itself doesn't look very 'openable' in order to fix it myself? Can I get just the connector from toyota or am I looking at a whole new MAF :/. Also, what gauge wire should I repair with?

Thanks guys!

Link to comment
Share on other sites

hi , mine did that too in exactly the same way. i ended up soldering mine back together.use some 5A speaker wire and extend the wires by about a 300mm and route them under the Typhoon rather that over.

post-73376-0-62121500-1323685028_thumb.j

Link to comment
Share on other sites

i think i pulled out the blue rubber bit then got my soldering iron in the hole and managed to join it to the other bit that snapped.someone on here told me how , the thread must be here somewhere.

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share





×
×
  • Create New...




Forums


News


Membership