Jump to content
Do Not Sell My Personal Information


Avensis 2.2 180 White Smoke


firstfixer
 Share

Recommended Posts

looks like I’ve got a white smoke problem when accelerating only done 50.000 on a 2006 2.2 180 .coolant level ok and bright pink. oil seems ok only used a litre in the last 5000 miles only difference in symptoms to others with same problem is no white streaks on plastic cover. Could it be anything else. any advice welcome thanks

Link to comment
Share on other sites

looks like I’ve got a white smoke problem when accelerating only done 50.000 on a 2006 2.2 180 .coolant level ok and bright pink. oil seems ok only used a litre in the last 5000 miles only difference in symptoms to others with same problem is no white streaks on plastic cover. Could it be anything else. any advice welcome thanks

-----------

hi matey

white smoke possible reasons:

- issue with crankshaft position sensor --- gives a wrong signal to ECU and then to each injector solenoids.

- issue with fuel filter clogging.

- issue with late injection timing (see 1st item).

- issue with ballance between air and fuel (?)

as vissible you have no issues with head gasket thanks to you have a coolant pink color yet and stable level.

Cheers/Igor

Link to comment
Share on other sites

the out of warranty cover by T is for up to 111K Miles or 7 years. so you have still a moment but I would certainly go and have it checked well before. if it's going you will get a new engine free of charge...

Link to comment
Share on other sites


igmorus, when do you get the white smoke? when the engine is cold or hot?

My 2.2 180 Auris is doing this now too, 51,000miles 2007. It isn't when the engine is stone cold, and it isn't when it's fully warmed up either. Every time I accelerate a bit harder, plumes of white smoke come out? No other symptoms.

Link to comment
Share on other sites

I thought it may be water vapour, but this is after 5 miles of driving and it never used to do it?

Again i hopen its the d cat doing its thing, but it happens nearly every day...

Link to comment
Share on other sites

There are many threads on the topic of the D-Cat system, as its an emission's reducing tool it will work harder in cold weather.

As long as the basic's are checked (Water,Oil, Clean EGR) and its serviced on time you cant do a lot more, assuming your not going to start driving a lot more miles the only decision to make is at the 7yr 112k point.

Unless it has a major issue but you cant legislate for that.

Link to comment
Share on other sites

hi Phil my avensis dose the same every day when accelerating doesn’t do it when cold . dose it when hot even on the motorway. if i keep to a constant speed it doesn’t do it a trip to mr t methinks

Steve

Link to comment
Share on other sites

mine t180 did this a couple of years ago new egr valve fitted and problem went away or so i thought but then it started to rev high on tick over. My car had always used coolent from new in the end i needed a new engine due to high oil consumption now i get just the odd puff of smoke which i put down to the d-cat regeneration has it is only every 200 miles or so

Link to comment
Share on other sites

looks like I’ve got a white smoke problem when accelerating only done 50.000 on a 2006 2.2 180 .coolant level ok and bright pink. oil seems ok only used a litre in the last 5000 miles only difference in symptoms to others with same problem is no white streaks on plastic cover. Could it be anything else. any advice welcome thanks

-----------

hi matey

white smoke possible reasons:

- issue with crankshaft position sensor --- gives a wrong signal to ECU and then to each injector solenoids.

- issue with fuel filter clogging.

- issue with late injection timing (see 1st item).

- issue with ballance between air and fuel (?)

as vissible you have no issues with head gasket thanks to you have a coolant pink color yet and stable level.

Cheers/Igor

Hi Igormus, Just booked in at Toyota for a diagnostic. Should the issues above show up when this is done?

Thanx Steve

Link to comment
Share on other sites

igmorus, when do you get the white smoke? when the engine is cold or hot?

My 2.2 180 Auris is doing this now too, 51,000miles 2007. It isn't when the engine is stone cold, and it isn't when it's fully warmed up either. Every time I accelerate a bit harder, plumes of white smoke come out? No other symptoms.

normally it goes when starting up in cold condition. but if you start it well then check with fuel filter; EGR and MAF sensor.

i do not believe you have injection timing issue. but usuaslly white smoke is caused in most cases by late of injection (after compression stroke) confirming the fuel is being heated but not ignited giving such white smoke

Link to comment
Share on other sites


I thought it may be water vapour, but this is after 5 miles of driving and it never used to do it?

Again i hopen its the d cat doing its thing, but it happens nearly every day...

firstly you'd find out the nature of this smoke -- is that water steam or unburnt diesel? it has either respective smell

Link to comment
Share on other sites

hi matey

white smoke possible reasons:

- issue with crankshaft position sensor --- gives a wrong signal to ECU and then to each injector solenoids.

- issue with fuel filter clogging.

- issue with late injection timing (see 1st item).

- issue with ballance between air and fuel (?)

as vissible you have no issues with head gasket thanks to you have a coolant pink color yet and stable level.

Cheers/Igor

Hi Igormus, Just booked in at Toyota for a diagnostic. Should the issues above show up when this is done?

Thanx Steve

Steve

they normally use a code reader just in case an errors are stored in.

but sometimes ECU shoess nothing and the conclusion of the mechanic is based on personal experience to deal with diesels

cheers

Link to comment
Share on other sites

Hi just got my car back from Toyota garage it went in for heavy smoke when accelerating . they cleaned egr and reprogrammed ecu what a difference hardly any smoke which they said would get better in a few days. It seems a lot quieter as well only concern they had was having to top up with a litre of oil told me to bring it back after 1000 miles.Id been keeping a watch on the oil and it was always on the heist mark on dip stick . when I check it now it’s over the mark and up to the top of the twist. Is this over filled are am I worrying over nothing.

Steve

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share





×
×
  • Create New...




Forums


News


Membership