Jump to content
Do Not Sell My Personal Information


Rav Still Not Running Right?


maddiemaisie
 Share

Recommended Posts

Hi, i have posted before as was having problems with my rav 4 (1995 2l petrol auto) it has not been running well for some time and using a lot of fuel, looses power at junctions, pulls back, cuts out, anyhow it went in for its MOT monday and failed on emmissions, the garage said everything was pointing to the oxygen sensor so a new one was put in and it then passed the MOT, since picking it up i have found it is very much the same still, drives ok while cold but after a few miles get progressively worse, as i pull away from junctions it loses all power and leaves me stranded in the middle of the road before kicking back in again and off we go, sometimes cuts out altogether. There is also on occasion a terrible rattling/banging noise coming from underneath (can feel the whole car rattling) and with the noise i also get a pull back. There was an advisory on the MOT for "rear diff bushes worn" I am at a total loss now as to what to do next (bareing in mind i have spent in excess of £900 on it over the past 9 months) So am desperate for ideas as to what the problem may be before taking it direct to the "toyota" garage HELP?????

Link to comment
Share on other sites

hi. not sure if this will help or not on the bushes part of the problem, but my celica GT4 4WD had an advisory on the rear bushes a long time back and a massive quote for replacments. The actual part that was worn would be a couple of quid but had no part number of its own so couls not be ordered and as one side would be done they said the other side must be.

Anyway ······· I took the car to a Japanese car specialust and they sorted it all out by a simple and very cheap repair rather then large unit replacements at high cost.

Maybe you will get a similar result trying out an independant specialist?

Link to comment
Share on other sites

Cutting out when hot may be caused by the crank sensor losing its signal due to the inductive coil breaking down. If the ECU does not see an AC voltage it cuts the fuel to the injectors.

Link to comment
Share on other sites

You need to find a good local independant garage. Those bushes are mendable = Bothwell Buyer will advise you.

The engine sounds very MAF sensor to me but all of the things spedo mention need checking. A good local guy will get to the bottom of it.

Link to comment
Share on other sites

Thankyou for your help, i will take it in to the garage again on Monday and have it looked at again, it is cutting out now every time i slow to a stop if i leave it in drive it splutters and cuts out, if i put it into neutral the revs pick back up and will then pull away ok, if i try to pull straight away while its in drive (without putting it in neutral first) it will start to pull away then splutter to a stop halfway across a junction.

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share





×
×
  • Create New...




Forums


News


Membership