Jump to content
Do Not Sell My Personal Information


Dmf Fixed But Still Getting Misfire + Loss Of Power


geordie_exile
 Share

Recommended Posts

Hi,

After 5 years of trouble free motoring in my 2002 d4d vx. Bang and my DMF is gone. Before it failed I was getting a vibration at low revs. But was also mis-firing. struggling to get above 3000 revs and if i floored it would get the engine light and limp mode. Leave it for a minute and restarts ok and engine light goes out.

I have now had it repaired at a cost of 1400. But engine is still misfiring. I have read somewhere that this could be related to the dmf problem via a crank sensor. Could this be the cause ? Or is this a seperate fault ? I have had it back to the garage and he thinks it's the EGR. Any ideas anyone.

Link to comment
Share on other sites


Welcome to TOC.

It sounds like the EGR valve to me. Its an easy job to clean! take look on here for the guide. What fuel are you using? have you ever used a fuel additive?

Link to comment
Share on other sites

Thanks for the welcome, Usually use BP but have used supermarkets in the past. Put in STP diesel injector cleaner last tank full. Then used v-power ( maybe too little too late) just took it on a 500 mile round trip to Cornwall without any engine lights. Which seems to have done it good, not misfiring as much now and I can accelerate. Not sure if it will last though.

Link to comment
Share on other sites

Hi

Warning light? Engine light did come on so I had to stop. Restarted and light went out no other lights tho..I have been following some threads on these forums regarding power loss and SCV's and EGR's do pop up a lot.

Link to comment
Share on other sites


Sorry anchorman, mechanic plugged in his code reader and said there where no fault codes stored. I was there when he plugged it in. According to his diagnostics everything was fine. But he said the symptoms point to the EGR. But without any codes it was just a guess. Options were run until engine light comes on and take it back to him or start changing bits. So far no more lights.

Link to comment
Share on other sites

due to vibration the SCV el contacts might play with you.

first of all you must to exclude DMF from the issues chain to go further

regards / Igor

Link to comment
Share on other sites

Hii

Just an update. Rav is running ok at the moment (touch wood) since my long trip to cornwall + STP injection cleaner added. But when I get 5 mins the first job will be to clean the EGR. Thanks to all who have replied.

Link to comment
Share on other sites

Just a thought but when dmf fails they throw a lot of swarf about, would be worth checking none is sticking to your flywheel sensor as a lot of them have magnetic propeties although would have thought whoever was changing dmf would have cleaned it but maybe not

Link to comment
Share on other sites

Well I thought that would have been checked. But saying that he did not renew the drive seals and he had to have it back as it was leaking oil all over my driveway. So I have not got the greatest of faith in the mechanic.

Link to comment
Share on other sites

I have serious vibrations from starting off now, so somethings not right, ok when warmed up or strangely, when I slip the clutch for a while, it goes away,.........can't help thinking its contamination on the clutch.......which would suggest a leak somwhere? I have noticed the brake fluid is a tad low,.......can this get on the clutch from the slave cylinder?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share





×
×
  • Create New...




Forums


News


Membership