Sign in to follow this  
Delboy141184

Carina E Pulling To The Left

Recommended Posts

Ok,my Carina E (1.8 lean burn) is pulling to the left.I just assumed it would be either incorrect air pressure or the tracking been out so had both checked at 2 different garages and they can confirm the tyre pressures are good,and the tracking is 100% perfect.

the tyres are like new,the wheels are not buckled or damaged.i did swap the 2 front tyres around to see if the problem persisted and it still pulls to the left.

I had a look at the last MOT certificate and it did state that the nearside lower ball joint had slight play in it so ive checked the ball joint and it does have some play.I am now thinking that this is what is causing the pulling and the 2 garages have both said the same thing.

My question is this....how do you change the lower ball joint on a Carina E? i have plenty of tools and some mechanical knowledge.i do not have a pickle fork/ball joint separator but could buy one no problem.The ball joint is available on ebay for around £10-£20 but i would be changing both lower ball joints on each side just as a matter of caution.

Is this something i can do myself? if some one could explain what steps i should take to change the lower ball joints i would be very much appreciative.

Thanks in advance.

Share this post


Link to post
Share on other sites

All you have to do when you get to the point of removing it if yer wana save money on a tool !! is to hold a hammer against one side of where the ball joint tapers in to the track control arm and hit the other side of it, with a bigger or better still a small lump hammer and it will shock it out of its taper fit. Hope that makes sense?

Share this post


Link to post
Share on other sites

got them replaced,had tracking re done,still pulling to the left???

Share this post


Link to post
Share on other sites

Try swopping the front wheels over could be a tyre off line a bit?

Share this post


Link to post
Share on other sites

sorry should have mentioned,ive done that already,basically,the tyres are like new all round,the air pressures are good,the wheels are not buckled or anything,the tracking has been checked 3 times and is bang on,new lower ball joints fitted this morning,and no un towards noises from front end which if you ask me eliminates any suspension components failing?

ruins a great ride it does.....

Share this post


Link to post
Share on other sites

If there wasn't any pulling to the left when you first had the new tyres fitted Then i guess there is no problem there. But altohough you say you have done that No harm in doing it again!?

If the rear tyres are uneven, then maybe the rear tracking wants looking at. Is there any play in the front suspension struts when you feel through the springs to the chorme piston bit moving the wheel at the bottom for play like you would for the ball joint?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this