Sign in to follow this  
cluo

Low Engine Coolant Temperature Indicator - Corolla Verso 2005

Recommended Posts

Hi,

I am new to this forum. I just bought my first Toyota Corolla Verso yesterday. But today when I start my car, the Low Engine Coolant temperature light (Blue color) is on. And after I drive about couple of minutes, it goes off. I am not sure whether this is normal? The outdoor temperature is about 19 'c. Hopefully someone could answer my question. Thanks!

Share this post


Link to post
Share on other sites

Never seen one but are you sure that its low temperature and not low coolant? Id be personally checking to see if you cars got enough coolant in it ;)

Share this post


Link to post
Share on other sites

Hi Steven,

Thanks for the reply. It's said on the brief guide, a blue light means "Low Engine Coolant temperature indicator light". and a red light means "High engine coolant temperature indicator light". My car is just serviced by the dealer. I assume the coolant should be full.

Share this post


Link to post
Share on other sites

Hi,

I am new to this forum. I just bought my first Toyota Corolla Verso yesterday. But today when I start my car, the Low Engine Coolant temperature light (Blue color) is on.

Its only to say the coolant/engine isn`t up to full temp yet.

Share this post


Link to post
Share on other sites

Hi dervdave,

So it is normal right? coz i never seen it on my old Renault. And I don't have the full user manual. Worried that it is a malfunction. :dontgetit:

Share this post


Link to post
Share on other sites

Normal but obviously check all the levels once a week.

Share this post


Link to post
Share on other sites

Well thats new to me a car having a cold coolant warning light..... I guess Some drivers have got that thick that they arent able to understand a tempature gauge so toyota need to fit a light... :rolleyes:

Share this post


Link to post
Share on other sites

Its normal. Once engine reaches temp it goes out. If you notice the Verso doesn't have a temperature gauge, well mine didn't. I had an 04 new shape so I'd assume an 05 would be the same.

Nice car, happy driving

Share this post


Link to post
Share on other sites

Hi paigerich,

yes, mine doesn't have the temperature gauge, and the light does go off after some time. Thanks for all your replies!

Share this post


Link to post
Share on other sites

Hi I am new to this forum pls I need to ask ,I have just bought a Toyota corolla verso 07 and two days ago a light showed up which says multimode system and the car could not move I don't understand what is going on can someone pls tell me if they have experience same problem thks

Share this post


Link to post
Share on other sites

Hi I am new to this forum pls I need to ask ,I have just bought a Toyota corolla verso 07 and two days ago a light showed up which says multimode system and the car could not move I don't understand what is going on can someone pls tell me if they have experience same problem thk

Hi,

This post is about a verso but not really relating to your probelm.

To be sure of getting maximum attention suggest you post it again as a New Topic.

Sorry, but cannot help with the "multimode system" not on my basic Corolla

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this