Sign in to follow this  
Andy Ward Innit

Head Lamps Working In Opposite Way ?!?

Recommended Posts

Hi,

I have an L reg '84 Carina E (2.0 GLi Estate) automatic.

I have noticed (mainly by people flashing me) that when the headlight stick is back (full beam) only normal dipped beam is on but the blue full beam light is on, when pulled forward one notch the full beam is on (no dash light), and when the stick is pulled full forward (for single full flash) then the lights go off !! Bonkers.

Is there anyway I can fix this (I cannot make head nor tail of the mass of cables around and don't have a Haynes manual) ?

Many Thanks in advance.

Share this post


Link to post
Share on other sites

Sounds like you need a new unit. If you undo the screws around the plastic suround cover you will see it attached to the steering collum

Just trace the loom wires from the switch unit to the block connector and disconnect

Share this post


Link to post
Share on other sites

no problem.

Let us all know how you get on once you have fitted it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this