Sign in to follow this  
TOYOTAJOHN

Ignition Switch Fault ?

Recommended Posts

Hi folks looking for info on a starting problem with my old avensis ,a few weeks ago i was having trouble starting car ,all the dash lights ok but but starter completely dead ,had new starter fitted and leads checked then ok for a couple of weeks, now having same problem again and have been told it might be the ignition switch which could be costly as i will need new switch,keys etc plus labour. ps car does start after about five turns of the key.any ideas ,comments etc very welcome thanks in advance.

Share this post


Link to post
Share on other sites

Bad earth connection? I've had a similar issue in the past where the earth strap had corroded and the started wouldn't turn (and I replaced the starter too ....) Or possibly immobiliser issue?

Share this post


Link to post
Share on other sites

It will be switch, it is a known fault. You don't have to change it all, only switch at bottom. Search on here you will find lots about it. New switch about £60 takes 20 minutes to change.

Share this post


Link to post
Share on other sites

Thanks for the helpful replys ,will check earth strap next weekend and if this does not fix it i will have see about ordering a new switch

Share this post


Link to post
Share on other sites

the switch is known for this, due to a bit of plastic wearing. I bought one new on ebay for about 30 quid and a mechanic replaced it in a few minutes

Share this post


Link to post
Share on other sites

Had the problem myself. It is the ignition switch at the end of the barrel. It took me about 25 minutes from first screw to install the new switch and finish the job.

It is a known Toyota issue and looking at other causes is wasting time.

A member has installed a starter button, saving wear on the switch (I think he did not bother changing the switch).

Share this post


Link to post
Share on other sites

Thanks to you all for the info, starter seems to be working ok at the moment but soon as it starts to play up again i will get a new switch .

Share this post


Link to post
Share on other sites

Thanks to you all for the info, starter seems to be working ok at the moment but soon as it starts to play up again i will get a new switch .

I put a 'starter button' on mine.

It may be ok at the moment, but if i were u , i'd do something now before the cold weather sets in and it leaves u stranded. be prepared is the motto :-)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this