Sign in to follow this  
TALS

Aygo Cd Player Not Working After Accident

Recommended Posts

Hi all,

I had an accident a couple of months ago in my aygo. I've recently got the car back from the garage and everything is working fine apart from the cd player. The radio and aux is working perfectly fine. When stationary, the cd player works fine! However as soon as i set off the cd skips just as if the disc is scratched. I bought a cd lens cleaner to try and fix the problem but that didn't work. Just wondering if anyone knows what the problem is or if anyone can give me advice on what to do?

Thanks in advance :)

Share this post


Link to post
Share on other sites

Sounds like something has got dislodged from the force of the accident.

Maybe cheaper getting a replacement rather than getting it repaired,

Share this post


Link to post
Share on other sites

As it appears it was damaged in the accident you should be able to add it to the claim - presumably all excesses have been paid, so you should be able to get it fixed or replaced for nowt extra.

Must have been quite an accident to do that though.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this