Sign in to follow this  
MeanMachine

Rattling Noise Help Please

Recommended Posts

I have a 2002 Toyota Previa 2.4 Auto GLS VVTI, I keep getting a rattling noise coming from the engine area when the engine is at optimum temperture and it only does this when the car is at low speed or rev and espeically when put into reverse. This is concerning me quite a bit as I have had a listen at the engine and it sounds like it is coming from underneath the heat sheild. I also have a tiny rattle in my backbox and dont know if this is connected in any way.

Any advice is much appreciated before I spend a fortune on stuff that doesn't need to be replaced.

Share this post


Link to post
Share on other sites

hello i have just had a similar problem with my toyota, the symptoms you have sound like what i had.

what is was is the baffle plate inside the rocker cover, the cause of the fault is jamming in a funnel when filling it with Oil it bends the baffle plate causing it to fracture and it catches on the camshaft lobe.

if you go down this path beware the breather pipe at the back of the engine become hard and brittle and will probably snap off.

Share this post


Link to post
Share on other sites

Sorry for the late reply, thank you for your input, I did have to replace the entire back box part as it completly rusted away from the mid pipe, but I still have this rattle and after reading your post I will get my garage guys to look at this.

I have been told so many things it could be including :- Catalytic converter, Engine mounts, Torque converter, Timing chain etc etc. If anyone else has any further info before I pay for things that the garage THINKS it is I would very much appreciate it.

Nothing has changed much as to how the rattling occurs, it is still when the engine heats up and at idle, low rev and in low gear and reverse. It has got a little louder and now there is a slight squeek from the engine if I shift from drive to reverse and vice versa.

Share this post


Link to post
Share on other sites

I have a verso and had a similar noise, found it to be the air intake into the air filter box, might not be your problem but thought I would share it just in case.

Share this post


Link to post
Share on other sites

Thank you for your input, I am currently awaiting the mid silencer to be replaced as that has now formed a split, it never ends lol

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this