Sign in to follow this  
BA553T

Vsc Limp Mode On Sr180

Recommended Posts

On my journey home tonight, i had to perform a 'foot down parked car pass' due to some numpty coming he other way at twice the legal limit round a bend. As i swerved round the parked car the VSC traction light flashed, followed by VSC and check engine error messages. The car dropped into limp mode.

As i was only 2 mins from my house i limped home, disconnected the Battery to reset the ECU and every thing seems fine.

I was wondering if anyone else had experienced this or knows what would of caused it, i'm slightly nervously as i'm using it to tour the lakes next week and don't want a repeat

I should point out the car is fitted with a Lindop tuning box, which i am chuffed to bits with. The box came set up by the the ever helpful kingo.

p.s. limpmode is a !Removed!, i could have walked the last bit quicker!!

cheers guys

Ba553t

Share this post


Link to post
Share on other sites

Check your PM's :)

sorry mate, but whats my PM's

Share this post


Link to post
Share on other sites

Click on your username at the top right hand corner of the webpage and select personal messages

Share this post


Link to post
Share on other sites

Sounds like the EGR valve needs a clean! Also try running V-Power derv and see how you get on. But I'm sure me mate Davey would have told you what the common problems are with the 2AD power units...

Share this post


Link to post
Share on other sites

Sounds like the EGR valve needs a clean! Also try running V-Power derv and see how you get on. But I'm sure me mate Davey would have told you what the common problems are with the 2AD power units...

Thanks Taff,

Already cleaned the EGR out around 2 months ago, wasn't too dirty (think its an updated unit compared with RickD4D's pinned guide to cleaning the EGR). I also ran some BG244 through straight afterwards, I have also just run some Forte DPF cleaner/regenerator through and the car is currently filled with V-power derv. I tend only use Shell or BP diesel, albeit it is usually regular diesel. I never use supermarket tat

Share this post


Link to post
Share on other sites

I had same the other week, found out that the missus had put in a tank of Asda diesel which the SR didn't like, especially with Lindops tuning box installed. Cleared it twice until I was able to get some proper diesel in - hasn't happened since. Most of the time I run Esso disel with a tank of V Power diesel or BP's Ultimate once a month.

Share this post


Link to post
Share on other sites

I had same the other week, found out that the missus had put in a tank of Asda diesel which the SR didn't like, especially with Lindops tuning box installed. Cleared it twice until I was able to get some proper diesel in - hasn't happened since. Most of the time I run Esso disel with a tank of V Power diesel or BP's Ultimate once a month.

Great minds think alike :) ... Thats' exactly what i was planning on doing, BP or Shell with a drop of their 'good stuff' one a month washed down with an annual dosing of BG244 and DPF cleaner and pray that the nasty diesel gremlins stay away.

Life was so much simpler in my 'petrol days'.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this