Sign in to follow this  
bigwizzer

High Idle On 1.0 Yaris

Recommended Posts

Hi guys new to the site I have a 2003 1.0 vvti Yaris serviced regularly never had a pick of bother now getting engine management message P0505 and she is idling at about 1200 per minute just carried out a service and cleaned the MAF sensor but she is still running high any one had a similar problem and what did you do to sort it

Cheers

Bigwizzer

Share this post


Link to post
Share on other sites

Moved to Yaris Forum from Supra ;)

Share this post


Link to post
Share on other sites

P0505 Relates to an Idle control malfunction, this is usually a faulty idle control valve ( located on the back of the throttle assembly ). New idle control valve needed & then the engine management light can be deleted.

Regards

Devon

Share this post


Link to post
Share on other sites

Cheers for the reply I had a idea that it eas the idle control valve just wanted it confirmed

Share this post


Link to post
Share on other sites

Cheers for the reply I had a idea that it eas the idle control valve just wanted it confirmed

Before you spend a lot of money! The idle speed control valve has two small coolant hoses attached to it. These have a very narrow bore and can block easily, the ISCV. 'thinks' the engine is cold as there is no circulation of coolant causing the problem you describe. You could easily spent a lot of money on a new valve, if the hoses are still blocked the problem will remain! Clean the hoses and flush any residue out of the valve to restore circulation. If you buy a new valve ensure you are sitting down when you are told the price!

Regards Geoff Peace.

Share this post


Link to post
Share on other sites

Cheers. Geoff I actuall gave her a service and completely removed the air filter and disconnected the pipes and blew the out I also removed the MAF sensor and cleaned it. Put it all back together and have been running it for about 4 hours and the idle is levelling out at around 650-700 so fingers crossed. This may have solved the problem.

Chris

Share this post


Link to post
Share on other sites

Hello Everybody.

My Yaris 2007 has been idling low for about 5 months and I only bothered now to look for a solution since it now also switches off randomly. How do I fix this problem? Do I need to flush the idling valve?

Share this post


Link to post
Share on other sites

P0505 Relates to an Idle control malfunction, this is usually a faulty idle control valve ( located on the back of the throttle assembly ). New idle control valve needed & then the engine management light can be deleted.

Regards

Devon

True! I agree with the above. However, I would try cleaning it first and blowing out the airways, nothing lost!

Regards Geoff Peace.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this