Sign in to follow this  
Telboy78

Economy Lamp?

Recommended Posts

Hello chaps, my first post so be gentle with me!!

Recently bought a 1998/T Avensis 2.0 GLS which I'm very impressed with - considering I came from a 2005 Peugeot 407 diesel!

Just a couple of questions I hope you can answer for me; In the handbook it mentions a green economy light? This doesn't appear to be working, or maybe my engine (2.0 petrol) doesn't have it fitted? Could someone confirm for me either way?

Secondly, seem to be experiencing a slight bit of clutch judder, pulling away in 1st and then upchanges to 2nd and sometimes third become a bit jerky and snappy. The clutch itself seems to be working, I can't detect any slip as far as I can tell. Symptom of the hydraulic system or something more sinister?

Any advice greatly appreciated. Oh and great forum by the way!

Share this post


Link to post
Share on other sites

Hi try adjusting the clutch pedal height to the correct height and the correct play at the pedal (approx 7mm)that might resolve the the gear changing problem .As for the green eco light you might have a blown bulb you'll have to take out the speedo housing and change it that way.

Share this post


Link to post
Share on other sites

Hi Telboy78, I'v just come from a 407 Diesel to a 2.2 Avensis. Peugeot = 52 motorway mpg, Avensis = 43 mpg and 30 around town. Missing my 407 already. As for you Eco lamp..... no idea.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this