Sign in to follow this  
tiggs

Mis Firing 02 Tsport

Recommended Posts

my 02 t sport corolla is misfiring changed coils changed front o2 sensor changed complete airbox and all sensors on air box maf sensor etc changed plugs but they gone black and carboned up but they not wet,battery is good , dosnt appear to have any leaky vacuum pipes, computer said random or multipl misfire please help what else can it be

Share this post


Link to post
Share on other sites

Any change you have a bad batch of fuel or problems with your fuel pump / injectors and what sort of engine fault codes did you get back?

When you pulled the plugs were they all the same colour or was one slightly off colour ? it might help indicate where your having the problem.

Share this post


Link to post
Share on other sites

Do a compression test on the engine,that will tell you if the internal health of the engine is ok before you go any further.

Mick

Share this post


Link to post
Share on other sites

plugs were all black, same colour , i havnt checked fuel or fuel pump, i dont think head gasket is blown and i havnt done a compression test, ill have to take it to garage for that. whats the worst thing that could be wrong with the engine? worst case senario? and any idea of cost to repair? thanks for your help.

Share this post


Link to post
Share on other sites

vvt solenoid faulty problems with timing so need new solenoid and if that dont work its a engine rebuild according to garage

Share this post


Link to post
Share on other sites

Hello Mr. tiggs!

From my experience fouled or carbon deposited spark plugs indicate one of:

1) Very rich (A/F ratio< 12) fuel mixture; Check fuel and air systems.

2)Incomplete combustion due to chain or timing belt misalignment.

3)Hung or improper valve timing due to VVTi system stuck occurrence.

4)Improper spark plug gap, improper spark plug hot/cold number.

5)Rarely coil or coil accessoires, such as rubber boot/s.

6)ECU firing output transistors failure.

With respect, averageuser

Share this post


Link to post
Share on other sites

changed broken vvt selonoid , engine idle ok but engine pinkin quite bad when you put your foot down when driving. timing chain is original and garage say its imposible for chain to jump tooth. so it apears timing is out but to be honest nobody as yet has any idea what wrong with this car.all coils and maf sensor and plugs and o2 sensor have been changed please help thanks for any comments

Share this post


Link to post
Share on other sites

Hi!

Pinking you hear happens when firing occurs before TDC, engine develops unusual toughness and dieseling (term), symptoms: very high low rpm torque, low maximum rpm, plugs are snow white and glazed. Remedy: There are technological marks (notches) on crankshaft and both camshafts - check incidence. All I wrote is only my opinion and not of professional mechanic.

Share this post


Link to post
Share on other sites

yes but why would timing be out if impossible for chain to jump tooth and is original chain

Share this post


Link to post
Share on other sites

Hello Sir!

In my opinion jump of chain highly improbable, but I heard only once this kind defect. It happened in my son's friend's 1.3 VVTi Vitz, due to loose chain hydraulic tensioner. I feel myself to bring you information I know, I don't claim it is true for 100%, but probability exists. Once again I'm not professional and hope this information will help you, honestly Sir.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this