Sign in to follow this  
Scottie4642

Avensis Estate Rear Wiper Problem.

Recommended Posts

My 1999 Avensis Estate has a rear wiper which will not stop wiping.

No Intermittent and no Stop, it wipes until the Ignition is turned off.

Can anyone provide an answer?

Share this post


Link to post
Share on other sites

I had the same problem last year, it was caused by dampness on the electrical connection to the rear window wiper motor, disconnect it from motor and dry with paper towel and let it dry out overnight before reconnecting in the morning, thats what i did and it has worked fine since.....

Share this post


Link to post
Share on other sites

Thanks, John.

I had disconnected the connection a few weeks ago and, thinking that it might be dampness, gave it a spray of the old WD40 befor re-connecting!

It made no difference so I will try your method now.

Strangely I had a problem with the "One shot" window control which stopped working and, suddenly after a few weeks, worked perfectly again!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this