Sign in to follow this  
perdaniel

Second Hand 1Az-Fse O2 Sensor?

Recommended Posts

Last night I got the error codes on my car scanned, it turned out that 3 of the oxygen sensors are defective (both in the first row and the first in the second row). After buying the car money is a little tight, so I'm looking into the possibility of using second hand sensors. Because Avensises with the 1AZ-FSE engine are about as rare as hens teeth here in Norway, I'm not finding any on the breaker yards websites. Are there any other Toyotas that use the same oxygen sensors, or will I have to pay the dealership 7000NOK (700£) for three brand new sensors?

Share this post


Link to post
Share on other sites

Could you not buy new from your local motor factor / store? Bosch often make a pattern part, failing that, PM me your chassis number and I will price new for you

Buying oxygen sensors second hand might prove costly in the long run, you could be replacing them again soo as you don't know the condition of the parts you are buying

Kingo :thumbsup:

Share this post


Link to post
Share on other sites

Hi. I had same engine and same problem few months ago. After the check engine light came on, the diagnostic said - O2 sensor. The mechanic asked me if I want to try and change the spark plugs becouse they look like they are pretty old and he is 80% sure they are the reason for the error. I changed them and my car was cured just for £50. So you can try. Hope you'll be lucky too.

Share this post


Link to post
Share on other sites

Hi. I had same engine and same problem few months ago. After the check engine light came on, the diagnostic said - O2 sensor. The mechanic asked me if I want to try and change the spark plugs becouse they look like they are pretty old and he is 80% sure they are the reason for the error. I changed them and my car was cured just for £50. So you can try. Hope you'll be lucky too.

That was interesting. As far as I know there are several different error codes related to the O2 sensors, the ones I got were, according to the test instrument, related to the heating elements of the O2 sensors. Was it the same error codes that you got? I have already ordered a second hand catalytic converter with all four O2 sensors for less than the price of one new O2 sensor, but I will also check the spark plugs.

Share this post


Link to post
Share on other sites

Mate, I have no idea what was the exact code, just i am telling what the mechanic told me. But if I try to think logical you have 3 o2 sensors gone at once! Right? So there is something that cause this problem - maybe unproperly burning fuel by diyng spark plugs?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this