kawakev

?accelerator

Recommended Posts

Hello

Not sure if its a problem with the accelerator pedal or with throttle body but a couple of times primarily when i start the car first thing in the morning, the engine screams out like the pedal is hard down. I kick it then revs go back to norm.

Anybody got ideas

Kev

Share this post


Link to post
Share on other sites
 

Its not clear from your post what year your car is ?

Around late 2003/2004 they switched to a drive by wire system.

The old system had a throttle cable going to the throttle body, the later system has a sensor mounted near the accelerator pedal and a motor in the throttle body.

Either way, first thing would be to first stick your head under the dash and check the accelerator mechanism especially any return springs.

Share this post


Link to post
Share on other sites

Hello

Not sure if its a problem with the accelerator pedal or with throttle body but a couple of times primarily when i start the car first thing in the morning, the engine screams out like the pedal is hard down. I kick it then revs go back to norm.

Anybody got ideas

Kev

it looks like the sound in question is an ABS self diagnostic/ it is quite normal for ABS

if no an alert on the clocks then nothing to worry about

regards

Share this post


Link to post
Share on other sites

Hi

The car is an early 2005, was wondering if it could be the sticky butterfly as mentioned in other posts.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...