Sign in to follow this  
Josho

Gearbox Issues

Recommended Posts

I recently purchased a 2003 Rav 2l petrol auto with 100k on the clock for £900.

Had the usual gearbox issues. It would pull away in 3rd, slip and generally be undrivable.

I resoldered resistors on the ECU and instantly the car drove fine so I thought.

Once warm, going from second to third the revs shoot up and it doesn't go in gear til revved to about 3500 where it then bangs into gear UNLESS you are caining the ***** off the car. If you have your foot down it shifts absolutely perfectly.

NO trouble going from 4th to 3rd just going from second to third.

Now the EML is on but there is an Exhaust sensor fault on the vehicle. I can't find my OBD2 scanner ANYWHERE so can't check the codes.

Any ideas? It's like it needs Oil pressure or something to get into gear.

It seems to shift fine when cold.

Obviously I do need to scan for codes but any ideas before I send it to a speciallist?

To be completely honest I'm looking at making a profit on the car as much as I actually really love it and it's the first non-German car I've owned that feels totally solid and reliable to drive.

It also averages 20MPG, I'm assuming this will be better when the sensor is sorted. I think I've spent about £70 quid and done 190 miles. :boxed:

In all fairness it has been thrashed about off road a lot yesterday.

Cheers guys!

Share this post


Link to post
Share on other sites

Hi Josho.

Firstly welcome to the club.

You say you "had the usual gearbox issues", so do we assume that you are aware that there is sometimes a prob on auto RAVs of that vintage that involves reprogamming the ECU and if this is not done the result can be a wrecked box?

Much has been written on here about this,so maybe trying the search box, if you have not already done so, may help.

This is not meant as a snide remark and the members,generally, are a really knowledgeable and will be happy to help you in any way that they possibly can.

I am afraid that the low 20's is all you will get,MPG wise, and that is without giving it some welly !!!

There was a list of members at one time of code reader owners who stated that they would be willing to read the codes for you if you were in their local vicinity

Del

Share this post


Link to post
Share on other sites

Good on ya mate.....yer Rav gearbox is gubbed, you are thrashing its boobies off driving it off road, it is returning woeful mpg, it requires the ECU well documented fix, but you would like to make a profit......Let's hope Stevie Wonder needs a Rav, eh.....?

Share this post


Link to post
Share on other sites

Hi Josho.

Firstly welcome to the club.

You say you "had the usual gearbox issues", so do we assume that you are aware that there is sometimes a prob on auto RAVs of that vintage that involves reprogamming the ECU and if this is not done the result can be a wrecked box?

Much has been written on here about this,so maybe trying the search box, if you have not already done so, may help.

This is not meant as a snide remark and the members,generally, are a really knowledgeable and will be happy to help you in any way that they possibly can.

I am afraid that the low 20's is all you will get,MPG wise, and that is without giving it some welly !!!

There was a list of members at one time of code reader owners who stated that they would be willing to read the codes for you if you were in their local vicinity

Del

Only a comment but my 4.2, auto, that has a mix of on and light off road use, in a very hilly part of Spain, returns high 20's under normal driving, and low 30's on trips. Thankfully the gearbox is ok ( keeps fingers crossed, lol) and I hope to have many years of use from the car in the future. :driving:

Share this post


Link to post
Share on other sites

Thank you to the first reply. Yes I am aware of the fault. Thanks. I have soldered it myself and it now drives which is good. It wouldn't go in first or second before but it does now.

Good on ya mate.....yer Rav gearbox is gubbed, you are thrashing its boobies off driving it off road, it is returning woeful mpg, it requires the ECU well documented fix, but you would like to make a profit......Let's hope Stevie Wonder needs a Rav, eh.....?

Well that's the thing last night was performing 100% offroad.

It was driving wofully crashing into every gear. I've resoldered some resistors and it drives fine if you give it beans but driving st low revs it just revs revs and revs while jerking then goes into 3rd.

Just unsure whether there is furthwr ECU issues or an internal fault with the box. Just wondering on any advice as have never really worked on autos.

Cheers.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this