Sign in to follow this  
Gav rav

Help No Power!

Recommended Posts

Hi all,

Just went through a road which was flooded up to about 30cm and after th Rav lost power and the engine light came on and said check 4x4 system, it also makes a funny noise when u rev. I tried calling Toyota and they are now closed for Xmas!

Does anyone have any ideas what I can do to make it better as got o drive 120miles tomorrow!?

Share this post


Link to post
Share on other sites

Sounds like you could have sucked up some water! Check pipes and see where you're upto! This wasn't in Barry was it by any chance? P/$Sing down here...

Share this post


Link to post
Share on other sites

Not long ago (so do a wee search....) Anchorman put up some photos as to where the air intake is on the Rav 4.3., Gavin.....when you see where it is, you need to guess and be erring on the safe side.......could water have got that high ( which surprisingly isn't that high )???? Could you have drawn water into engine....?

Check also air filter housing and filter itself.....wet or not.....?

Besta Luck,

Big Kev

Share this post


Link to post
Share on other sites

How fast did you hit that flood ?

As above.........

You may have sucked some water into air intake...which i believe is behind your nearside headlight,you may now have a wet air filter ??.

Share this post


Link to post
Share on other sites

Mmmmm not good. Looks like you may have drawn water into the engine through the air intake system. I would be inclined to check for water in the air inlet system and make sure that the air filter is dry. I would also be inclined not to be driving it anywhere until I have had it checked over.

Best of luck with it mate.

Blimey 3 replies in the time that it took me to type this reply. Fast fingers on this forum.

Share this post


Link to post
Share on other sites

Cheers guys, i will take a look now, although i didnt hit the water fast and it didnt go as high as headlight?

will report back soon

Share this post


Link to post
Share on other sites

Just checked the air filter and housing both are dry!? Started the car and check vsc and check 4x4 system still coming up along with the check engine? I took it for a drive and car felt fine but then it went into the safety mode and couldn't rev and had no power so came home. Really don't know what to do now?

Share this post


Link to post
Share on other sites

Thanks for that link, it does sound as if I have that problem! I think it's going to be very expensive this!

Share this post


Link to post
Share on other sites

Had the AA out today and their diagnostic said it's a code P2002 DPF fault!? He tried resetting but it kicked back in then, the AA guy said it could be could it went through water, am gutted as thought the Rav was a 4x4!?

Share this post


Link to post
Share on other sites

Had the AA out today and their diagnostic said it's a code P2002 DPF fault!? He tried resetting but it kicked back in then, the AA guy said it could be could it went through water, am gutted as thought the Rav was a 4x4!?

Aye Gav.....but it's no called Bobby McGregor.....!!!!! Good luck.....hope it's not as expensive as all our brains always expect it to be.....then we get a surprise.....it's worserer :thumbsup:

Share this post


Link to post
Share on other sites

Had the AA out today and their diagnostic said it's a code P2002 DPF fault!? He tried resetting but it kicked back in then, the AA guy said it could be could it went through water, am gutted as thought the Rav was a 4x4!?

Indeed it is, but it's not a submarine.

You need to give a bit more info so that folks on here are able to help, e.g. did you drive through standing water, how deep, when, anything else unusual happening around same time (misfires, fuelling, etc.), is service history clean, etc., etc. ?????

Sorry, forget the above. I didn't read page 1 first where you have noted the details. I blame the Xmas pud....... :drunk::oops:

Share this post


Link to post
Share on other sites

Just had toyota call and they reckon dpf needs to be replaced and they found an Oil leak so not good, they said its going to cost around £3k! am gutted and have asked them to see if toyota can do anything even though its out of warrenty?!

does anyone have any helpful suggestions?

cheers

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this