Sign in to follow this  
sotal

After A Gen7

Recommended Posts

It's been a long time since I had my gen6 Celica and this forum has changed massively since! I can see a few of the old members are still here though.

I'm just looking at swapping in one of our cars at the moment always wanted to try the gen7 at some point and they seem so cheap now that it would be rude not to.

I'm just a bit fussy so haven't actually found one to suit yet!

Its got to be/have:

190bhp

Rear spoiler

Different alloys (I'd prefer factory alloys but just not the standard ones that came on most)

Leather seats

Dark Blue, Storm Grey preferred but would also have red or silver.

So if anyone sees one to suit please let me know,

My actual question is - I'm a bit rusty on these - is there anything to look out for. I remember an issue with lift bolts - I presume this would be sorted by now?? I remember to check that the boot holds itself up, other than that I can't remember much more!

Thanks

Share this post


Link to post
Share on other sites

With the lift bolts, you would be fine with a facelift model (03 onwards). However if you got a prefacelift the bolts are cheap & easy to replace yourself, providing they have not snapped. If the car engages lift easily over 6k revs (engine needs to be warm), then the lift bolts have not snapped.

Share this post


Link to post
Share on other sites

Hi there edwardio; I am in a similar position to sotal in wanting to purchase a Gen7. At what age was the Oil usage issue resolved?

Thx

Share this post


Link to post
Share on other sites

The Oil useage issue was resolved on the facelift 140's. Please note ALL pre-facelift 140's have the design flaw that can cause the Oil burning issue. so 1999-52 is the pre-facelift. 03> is facelift. Another is way to tell is facelift 140's & 190's have a slotted front grill & round style rear lights.

The Oil burning issue arrives through using cheap Oil for too long, incorrect servicing intervals and not treating the car properly.

Share this post


Link to post
Share on other sites

Ok thanks for that. Was it on the 190 unit too (presumably they are the same engine just tweaked)?

So perhaps go for a 2003 onwards with FSH and hope for the best?!

Oh and change the bolts as above!

Thx for the feedback; sorry for hijacking sotal's thread

Share this post


Link to post
Share on other sites

No the 140 has a 1ZZ engine, the 190 a 2ZZ. Completely different engines.

Share this post


Link to post
Share on other sites

So the 2ZZ engine has never had the Oil usage issue?

Thanks your patience with a newbie btw

Share this post


Link to post
Share on other sites

No the 2ZZ never had the Oil issue. Only the early models had the lift bolt issue.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this